aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-08-26 13:55:08 -0400
committerLibravatar GitHub <noreply@github.com>2018-08-26 13:55:08 -0400
commit6afc0590a1ad1b2d7f8276d34a607e8b61fbb6ca (patch)
treee5e4a423a3a14075735ec551587df2bb47a36d02 /meson.build
parentMerge pull request #2513 from RyanDwyer/rename-root-outputs (diff)
parentadded fish to meson.build (diff)
downloadsway-6afc0590a1ad1b2d7f8276d34a607e8b61fbb6ca.tar.gz
sway-6afc0590a1ad1b2d7f8276d34a607e8b61fbb6ca.tar.zst
sway-6afc0590a1ad1b2d7f8276d34a607e8b61fbb6ca.zip
Merge pull request #2517 from fokditkak/add_fish_completion
Add fish completion
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2a020323..0e4b4f21 100644
--- a/meson.build
+++ b/meson.build
@@ -205,3 +205,14 @@ if (get_option('bash_completions'))
205 205
206 install_data(bash_files, install_dir: bash_install_dir) 206 install_data(bash_files, install_dir: bash_install_dir)
207endif 207endif
208
209if (get_option('fish_completions'))
210 fish_files = files(
211 'completions/fish/sway.fish',
212 'completions/fish/swaylock.fish',
213 'completions/fish/swaymsg.fish',
214 )
215 fish_install_dir = datadir + '/fish/completions'
216
217 install_data(fish_files, install_dir: fish_install_dir)
218endif