aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-03-27 15:25:25 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2018-03-28 14:25:19 -0400
commit632bb948b7ffbb08a6e965dabf88347afd0a1fa8 (patch)
treecbd9d4e4e3a7c605d2b0a5e3e66ce35554a74c4b /meson.build
parentAdd client protocols and swaybg skeleton (diff)
downloadsway-632bb948b7ffbb08a6e965dabf88347afd0a1fa8.tar.gz
sway-632bb948b7ffbb08a6e965dabf88347afd0a1fa8.tar.zst
sway-632bb948b7ffbb08a6e965dabf88347afd0a1fa8.zip
Add solid-color rendering to swaybg
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 622769a3..0c35b0e5 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,10 @@ wayland_client = dependency('wayland-client')
27wayland_egl = dependency('wayland-egl') 27wayland_egl = dependency('wayland-egl')
28wayland_protos = dependency('wayland-protocols') 28wayland_protos = dependency('wayland-protocols')
29xkbcommon = dependency('xkbcommon') 29xkbcommon = dependency('xkbcommon')
30cairo = dependency('cairo')
30pango = dependency('pango') 31pango = dependency('pango')
32pangocairo = dependency('pangocairo')
33gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: false)
31pixman = dependency('pixman-1') 34pixman = dependency('pixman-1')
32libcap = dependency('libcap') 35libcap = dependency('libcap')
33libinput = dependency('libinput') 36libinput = dependency('libinput')
@@ -35,6 +38,10 @@ math = cc.find_library('m')
35git = find_program('git', required: false) 38git = find_program('git', required: false)
36a2x = find_program('a2x', required: false) 39a2x = find_program('a2x', required: false)
37 40
41if gdk_pixbuf.found()
42 add_project_arguments('-DWITH_GDK_PIXBUF', language : 'c')
43endif
44
38if a2x.found() 45if a2x.found()
39 mandir = get_option('mandir') 46 mandir = get_option('mandir')
40 man_files = [ 47 man_files = [
@@ -89,6 +96,7 @@ subdir('protocols')
89subdir('common') 96subdir('common')
90subdir('sway') 97subdir('sway')
91subdir('swaymsg') 98subdir('swaymsg')
99subdir('client')
92subdir('swaybg') 100subdir('swaybg')
93 101
94config = configuration_data() 102config = configuration_data()