aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar emersion <contact@emersion.fr>2018-11-12 22:23:06 +0100
committerLibravatar emersion <contact@emersion.fr>2018-11-12 22:23:06 +0100
commit2afd930914c9d31ed1da5ffd80b18f029e84f8c5 (patch)
tree52157267467d84cd9ce83265ca4b600b1b802af1 /meson.build
parentMerge pull request #3116 from harishkrupo/master (diff)
downloadsway-2afd930914c9d31ed1da5ffd80b18f029e84f8c5.tar.gz
sway-2afd930914c9d31ed1da5ffd80b18f029e84f8c5.tar.zst
sway-2afd930914c9d31ed1da5ffd80b18f029e84f8c5.zip
Use #if instead of #ifdef for WLR_HAS_*
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 11 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 6b23b4e3..8327b763 100644
--- a/meson.build
+++ b/meson.build
@@ -9,11 +9,17 @@ project(
9 ], 9 ],
10) 10)
11 11
12add_project_arguments('-Wno-unused-parameter', language: 'c') 12add_project_arguments(
13add_project_arguments('-Wno-unused-function', language: 'c') 13 [
14add_project_arguments('-Wno-unused-result', language: 'c') 14 '-DWL_HIDE_DEPRECATED',
15add_project_arguments('-DWL_HIDE_DEPRECATED', language: 'c') 15 '-DWLR_USE_UNSTABLE',
16add_project_arguments('-DWLR_USE_UNSTABLE', language: 'c') 16
17 '-Wno-unused-parameter',
18 '-Wno-unused-result',
19 '-Wundef',
20 ],
21 language: 'c',
22)
17 23
18cc = meson.get_compiler('c') 24cc = meson.get_compiler('c')
19 25