aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar sghctoma <sghctoma@gmail.com>2018-09-03 08:57:17 +0200
committerLibravatar sghctoma <sghctoma@gmail.com>2018-09-03 08:57:17 +0200
commitdf730a88919b078093dbc322926ada219a60d036 (patch)
treef2837f24092c7be5dfccdf448e47062cb5718549 /meson.build
parentEnable privilege dropping of FreeBSD (diff)
parentMerge pull request #2553 from emersion/disabled-no-modeset (diff)
downloadsway-df730a88919b078093dbc322926ada219a60d036.tar.gz
sway-df730a88919b078093dbc322926ada219a60d036.tar.zst
sway-df730a88919b078093dbc322926ada219a60d036.zip
Merge remote-tracking branch 'upstream/master' into fix-freebsd-build
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 7 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 57b024c8..253a4e96 100644
--- a/meson.build
+++ b/meson.build
@@ -106,7 +106,7 @@ endif
106 106
107add_project_arguments('-DSYSCONFDIR="/@0@/@1@"'.format(prefix, sysconfdir), language : 'c') 107add_project_arguments('-DSYSCONFDIR="/@0@/@1@"'.format(prefix, sysconfdir), language : 'c')
108 108
109version = get_option('sway_version') 109version = get_option('sway-version')
110if version != '' 110if version != ''
111 version = '"@0@"'.format(version) 111 version = '"@0@"'.format(version)
112else 112else
@@ -120,6 +120,8 @@ else
120endif 120endif
121add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c') 121add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
122 122
123add_project_arguments('-D_LD_LIBRARY_PATH="@0@"'.format(get_option('ld-library-path')), language: 'c')
124
123sway_inc = include_directories('include') 125sway_inc = include_directories('include')
124 126
125subdir('include') 127subdir('include')
@@ -168,7 +170,7 @@ install_data(
168 install_dir: datadir + '/wayland-sessions' 170 install_dir: datadir + '/wayland-sessions'
169) 171)
170 172
171if (get_option('default_wallpaper')) 173if (get_option('default-wallpaper'))
172 wallpaper_files = files( 174 wallpaper_files = files(
173 'assets/Sway_Wallpaper_Blue_768x1024.png', 175 'assets/Sway_Wallpaper_Blue_768x1024.png',
174 'assets/Sway_Wallpaper_Blue_768x1024_Portrait.png', 176 'assets/Sway_Wallpaper_Blue_768x1024_Portrait.png',
@@ -184,7 +186,7 @@ if (get_option('default_wallpaper'))
184 install_data(wallpaper_files, install_dir: wallpaper_install_dir) 186 install_data(wallpaper_files, install_dir: wallpaper_install_dir)
185endif 187endif
186 188
187if (get_option('zsh_completions')) 189if (get_option('zsh-completions'))
188 zsh_files = files( 190 zsh_files = files(
189 'completions/zsh/_sway', 191 'completions/zsh/_sway',
190 'completions/zsh/_swaylock', 192 'completions/zsh/_swaylock',
@@ -195,7 +197,7 @@ if (get_option('zsh_completions'))
195 install_data(zsh_files, install_dir: zsh_install_dir) 197 install_data(zsh_files, install_dir: zsh_install_dir)
196endif 198endif
197 199
198if (get_option('bash_completions')) 200if (get_option('bash-completions'))
199 bash_files = files( 201 bash_files = files(
200 'completions/bash/sway', 202 'completions/bash/sway',
201 'completions/bash/swayidle', 203 'completions/bash/swayidle',
@@ -207,7 +209,7 @@ if (get_option('bash_completions'))
207 install_data(bash_files, install_dir: bash_install_dir) 209 install_data(bash_files, install_dir: bash_install_dir)
208endif 210endif
209 211
210if (get_option('fish_completions')) 212if (get_option('fish-completions'))
211 fish_files = files( 213 fish_files = files(
212 'completions/fish/sway.fish', 214 'completions/fish/sway.fish',
213 'completions/fish/swaylock.fish', 215 'completions/fish/swaylock.fish',