summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2019-02-27 16:00:28 -0500
committerLibravatar GitHub <noreply@github.com>2019-02-27 16:00:28 -0500
commitaea33551fb517a47533b87338da1ccb8a3f0c1a5 (patch)
treee0d5735a7f6e40114673234838c9e08f287958bf /meson.build
parentconfig: remove double assignement to result in get_output_config (diff)
parentPrint Meson features (diff)
downloadsway-aea33551fb517a47533b87338da1ccb8a3f0c1a5.tar.gz
sway-aea33551fb517a47533b87338da1ccb8a3f0c1a5.tar.zst
sway-aea33551fb517a47533b87338da1ccb8a3f0c1a5.zip
Merge pull request #3787 from emersion/meson-print-features
Print Meson features
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build23
1 files changed, 18 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index d3172bdd..3c3c1f41 100644
--- a/meson.build
+++ b/meson.build
@@ -93,11 +93,6 @@ conf_data.set10('HAVE_SYSTEMD', systemd.found())
93conf_data.set10('HAVE_ELOGIND', elogind.found()) 93conf_data.set10('HAVE_ELOGIND', elogind.found())
94conf_data.set10('HAVE_TRAY', have_tray) 94conf_data.set10('HAVE_TRAY', have_tray)
95 95
96if not systemd.found() and not elogind.found()
97 warning('The sway binary must be setuid when compiled without (e)logind')
98 warning('You must do this manually post-install: chmod a+s /path/to/sway')
99endif
100
101scdoc = find_program('scdoc', required: get_option('man-pages')) 96scdoc = find_program('scdoc', required: get_option('man-pages'))
102if scdoc.found() 97if scdoc.found()
103 sh = find_program('sh') 98 sh = find_program('sh')
@@ -235,3 +230,21 @@ if get_option('fish-completions')
235 230
236 install_data(fish_files, install_dir: fish_install_dir) 231 install_data(fish_files, install_dir: fish_install_dir)
237endif 232endif
233
234status = [
235 '',
236 'Features:',
237 'xwayland: @0@'.format(have_xwayland),
238 'gdk-pixbuf: @0@'.format(gdk_pixbuf.found()),
239 'systemd: @0@'.format(systemd.found()),
240 'elogind: @0@'.format(elogind.found()),
241 'tray: @0@'.format(have_tray),
242 'man-pages: @0@'.format(scdoc.found()),
243 '',
244]
245message('\n'.join(status))
246
247if not systemd.found() and not elogind.found()
248 warning('The sway binary must be setuid when compiled without (e)logind')
249 warning('You must do this manually post-install: chmod a+s /path/to/sway')
250endif