aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2019-02-27 16:01:27 -0500
committerLibravatar GitHub <noreply@github.com>2019-02-27 16:01:27 -0500
commit51d27d154950824228e91eb1af0374a21fe4e1c5 (patch)
tree2e96973a01c2a780d032033558d99865a01fd975 /meson.build
parentMerge pull request #3787 from emersion/meson-print-features (diff)
parentSet minimum wlroots version (diff)
downloadsway-51d27d154950824228e91eb1af0374a21fe4e1c5.tar.gz
sway-51d27d154950824228e91eb1af0374a21fe4e1c5.tar.zst
sway-51d27d154950824228e91eb1af0374a21fe4e1c5.zip
Merge pull request #3786 from emersion/wlroots-version
Set minimum wlroots version
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3c3c1f41..3ba1e0c3 100644
--- a/meson.build
+++ b/meson.build
@@ -60,17 +60,19 @@ rt = cc.find_library('rt')
60git = find_program('git', required: false) 60git = find_program('git', required: false)
61 61
62# Try first to find wlroots as a subproject, then as a system dependency 62# Try first to find wlroots as a subproject, then as a system dependency
63wlroots_version = '>=0.4.1'
63wlroots_proj = subproject( 64wlroots_proj = subproject(
64 'wlroots', 65 'wlroots',
65 default_options: ['rootston=false', 'examples=false'], 66 default_options: ['rootston=false', 'examples=false'],
66 required: false, 67 required: false,
68 version: wlroots_version,
67) 69)
68if wlroots_proj.found() 70if wlroots_proj.found()
69 wlroots = wlroots_proj.get_variable('wlroots') 71 wlroots = wlroots_proj.get_variable('wlroots')
70 wlroots_conf = wlroots_proj.get_variable('conf_data') 72 wlroots_conf = wlroots_proj.get_variable('conf_data')
71 wlroots_has_xwayland = wlroots_conf.get('WLR_HAS_XWAYLAND') == 1 73 wlroots_has_xwayland = wlroots_conf.get('WLR_HAS_XWAYLAND') == 1
72else 74else
73 wlroots = dependency('wlroots') 75 wlroots = dependency('wlroots', version: wlroots_version)
74 wlroots_has_xwayland = cc.get_define('WLR_HAS_XWAYLAND', prefix: '#include <wlr/config.h>', dependencies: wlroots) == '1' 76 wlroots_has_xwayland = cc.get_define('WLR_HAS_XWAYLAND', prefix: '#include <wlr/config.h>', dependencies: wlroots) == '1'
75endif 77endif
76 78