aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2015-11-12 19:04:01 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2015-11-12 19:04:01 -0500
commitbfcabe48ef3fc7a0388de007504fc232f826fb84 (patch)
tree8bef61a10259765dbafed49c9a2a76b4bf9ced2d /CMakeLists.txt
parentMerge branch 'master' of github.com:SirCmpwn/sway (diff)
downloadsway-bfcabe48ef3fc7a0388de007504fc232f826fb84.tar.gz
sway-bfcabe48ef3fc7a0388de007504fc232f826fb84.tar.zst
sway-bfcabe48ef3fc7a0388de007504fc232f826fb84.zip
Start fleshing out wayland client implementation
This introduces a basic shared framework for making wayland clients within sway itself.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d446c2b3..b75e8737 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ set(CMAKE_C_FLAGS "-g")
4set(CMAKE_C_STANDARD 99) 4set(CMAKE_C_STANDARD 99)
5SET(CMAKE_C_EXTENSIONS OFF) 5SET(CMAKE_C_EXTENSIONS OFF)
6set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "bin/") 6set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "bin/")
7add_definitions("-Wall -Wextra -Wno-unused-parameter") 7add_definitions("-Wall -Wextra -Wno-unused-parameter -D_GNU_SOURCE")
8set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/CMake) 8set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/CMake)
9 9
10add_subdirectory(swaybg swaybg) 10add_subdirectory(swaybg swaybg)
@@ -44,6 +44,7 @@ find_package(PCRE REQUIRED)
44find_package(JsonC REQUIRED) 44find_package(JsonC REQUIRED)
45 45
46FILE(GLOB sources ${PROJECT_SOURCE_DIR}/sway/*.c) 46FILE(GLOB sources ${PROJECT_SOURCE_DIR}/sway/*.c)
47FILE(GLOB common ${PROJECT_SOURCE_DIR}/common/*.c)
47 48
48include_directories( 49include_directories(
49 ${WLC_INCLUDE_DIRS} 50 ${WLC_INCLUDE_DIRS}
@@ -55,6 +56,7 @@ include_directories(
55 56
56add_executable(sway 57add_executable(sway
57 ${sources} 58 ${sources}
59 ${common}
58) 60)
59 61
60target_link_libraries(sway 62target_link_libraries(sway