aboutsummaryrefslogtreecommitdiffstats
path: root/packages/main/src/reactions
diff options
context:
space:
mode:
Diffstat (limited to 'packages/main/src/reactions')
-rw-r--r--packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts8
-rw-r--r--packages/main/src/reactions/loadServices.ts2
-rw-r--r--packages/main/src/reactions/synchronizeConfig.ts2
-rw-r--r--packages/main/src/reactions/synchronizeNativeTheme.ts2
4 files changed, 6 insertions, 8 deletions
diff --git a/packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts b/packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts
index d3338d0..403a608 100644
--- a/packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts
+++ b/packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts
@@ -24,21 +24,19 @@ import { mocked } from 'jest-mock';
24import type ConfigRepository from '../../infrastructure/config/ConfigRepository'; 24import type ConfigRepository from '../../infrastructure/config/ConfigRepository';
25import SharedStore from '../../stores/SharedStore'; 25import SharedStore from '../../stores/SharedStore';
26import type Disposer from '../../utils/Disposer'; 26import type Disposer from '../../utils/Disposer';
27import { silenceLogger } from '../../utils/log';
28import synchronizeConfig, { serializeConfig } from '../synchronizeConfig'; 27import synchronizeConfig, { serializeConfig } from '../synchronizeConfig';
29 28
30let store: SharedStore; 29let store: SharedStore;
31const repository: ConfigRepository = { 30const repository: ConfigRepository = {
32 readConfig: jest.fn(), 31 readConfig: jest.fn<ConfigRepository['readConfig']>(),
33 writeConfig: jest.fn(), 32 writeConfig: jest.fn<ConfigRepository['writeConfig']>(),
34 watchConfig: jest.fn(), 33 watchConfig: jest.fn<ConfigRepository['watchConfig']>(),
35}; 34};
36const lessThanThrottleMs = 100; 35const lessThanThrottleMs = 100;
37const throttleMs = 1000; 36const throttleMs = 1000;
38 37
39beforeAll(() => { 38beforeAll(() => {
40 jest.useFakeTimers(); 39 jest.useFakeTimers();
41 silenceLogger();
42}); 40});
43 41
44beforeEach(() => { 42beforeEach(() => {
diff --git a/packages/main/src/reactions/loadServices.ts b/packages/main/src/reactions/loadServices.ts
index f56ac62..50fd2cb 100644
--- a/packages/main/src/reactions/loadServices.ts
+++ b/packages/main/src/reactions/loadServices.ts
@@ -29,7 +29,7 @@ import type {
29} from '../infrastructure/electron/types'; 29} from '../infrastructure/electron/types';
30import type MainStore from '../stores/MainStore'; 30import type MainStore from '../stores/MainStore';
31import type Service from '../stores/Service'; 31import type Service from '../stores/Service';
32import { getLogger } from '../utils/log'; 32import getLogger from '../utils/getLogger';
33 33
34const log = getLogger('loadServices'); 34const log = getLogger('loadServices');
35 35
diff --git a/packages/main/src/reactions/synchronizeConfig.ts b/packages/main/src/reactions/synchronizeConfig.ts
index 247c2e2..5fe924a 100644
--- a/packages/main/src/reactions/synchronizeConfig.ts
+++ b/packages/main/src/reactions/synchronizeConfig.ts
@@ -25,7 +25,7 @@ import type ConfigRepository from '../infrastructure/config/ConfigRepository';
25import type SharedStore from '../stores/SharedStore'; 25import type SharedStore from '../stores/SharedStore';
26import type Config from '../stores/config/Config'; 26import type Config from '../stores/config/Config';
27import type Disposer from '../utils/Disposer'; 27import type Disposer from '../utils/Disposer';
28import { getLogger } from '../utils/log'; 28import getLogger from '../utils/getLogger';
29 29
30const DEFAULT_CONFIG_DEBOUNCE_TIME_MS = 1000; 30const DEFAULT_CONFIG_DEBOUNCE_TIME_MS = 1000;
31 31
diff --git a/packages/main/src/reactions/synchronizeNativeTheme.ts b/packages/main/src/reactions/synchronizeNativeTheme.ts
index 8c4edb3..384d54d 100644
--- a/packages/main/src/reactions/synchronizeNativeTheme.ts
+++ b/packages/main/src/reactions/synchronizeNativeTheme.ts
@@ -23,7 +23,7 @@ import { autorun } from 'mobx';
23 23
24import type SharedStore from '../stores/SharedStore'; 24import type SharedStore from '../stores/SharedStore';
25import type Disposer from '../utils/Disposer'; 25import type Disposer from '../utils/Disposer';
26import { getLogger } from '../utils/log'; 26import getLogger from '../utils/getLogger';
27 27
28const log = getLogger('synchronizeNativeTheme'); 28const log = getLogger('synchronizeNativeTheme');
29 29