aboutsummaryrefslogtreecommitdiffstats
path: root/packages/main/src/stores/__tests__
diff options
context:
space:
mode:
authorLibravatar Kristóf Marussy <kristof@marussy.com>2022-05-09 01:37:06 +0200
committerLibravatar Kristóf Marussy <kristof@marussy.com>2022-05-16 00:55:03 +0200
commita6fade92974dbba63a7d7a07f80bb447dfdf4f5b (patch)
tree8c7dfc3cc4a041412cc6be9a260acc8238b78013 /packages/main/src/stores/__tests__
parenttest: prefer jest API instead of jest-each (diff)
downloadsophie-a6fade92974dbba63a7d7a07f80bb447dfdf4f5b.tar.gz
sophie-a6fade92974dbba63a7d7a07f80bb447dfdf4f5b.tar.zst
sophie-a6fade92974dbba63a7d7a07f80bb447dfdf4f5b.zip
test: use test instead of it
Signed-off-by: Kristóf Marussy <kristof@marussy.com>
Diffstat (limited to 'packages/main/src/stores/__tests__')
-rw-r--r--packages/main/src/stores/__tests__/SharedStore.test.ts (renamed from packages/main/src/stores/__tests__/SharedStore.spec.ts)16
1 files changed, 8 insertions, 8 deletions
diff --git a/packages/main/src/stores/__tests__/SharedStore.spec.ts b/packages/main/src/stores/__tests__/SharedStore.test.ts
index 268ce3f..0ed63e3 100644
--- a/packages/main/src/stores/__tests__/SharedStore.spec.ts
+++ b/packages/main/src/stores/__tests__/SharedStore.test.ts
@@ -39,7 +39,7 @@ beforeEach(() => {
39}); 39});
40 40
41describe('loadConfig', () => { 41describe('loadConfig', () => {
42 it('should load profiles with an ID', () => { 42 test('loads profiles with an ID', () => {
43 sut.loadConfig({ 43 sut.loadConfig({
44 profiles: [ 44 profiles: [
45 { 45 {
@@ -51,14 +51,14 @@ describe('loadConfig', () => {
51 expect(sut.profiles[0].id).toBe('someId'); 51 expect(sut.profiles[0].id).toBe('someId');
52 }); 52 });
53 53
54 it('should generate an ID for profiles without and ID', () => { 54 test('generates an ID for profiles without and ID', () => {
55 sut.loadConfig({ 55 sut.loadConfig({
56 profiles: [profileProps], 56 profiles: [profileProps],
57 }); 57 });
58 expect(sut.profiles[0].id).toBeDefined(); 58 expect(sut.profiles[0].id).toBeDefined();
59 }); 59 });
60 60
61 it('should load services with an ID and a profile', () => { 61 test('loads services with an ID and a profile', () => {
62 sut.loadConfig({ 62 sut.loadConfig({
63 profiles: [ 63 profiles: [
64 { 64 {
@@ -78,7 +78,7 @@ describe('loadConfig', () => {
78 expect(sut.services[0].settings.profile).toBe(sut.profiles[0]); 78 expect(sut.services[0].settings.profile).toBe(sut.profiles[0]);
79 }); 79 });
80 80
81 it('should refuse to load a profile without a name', () => { 81 test('refuses to load a profile without a name', () => {
82 expect(() => { 82 expect(() => {
83 sut.loadConfig({ 83 sut.loadConfig({
84 profiles: [ 84 profiles: [
@@ -93,7 +93,7 @@ describe('loadConfig', () => {
93 expect(sut.profiles).toHaveLength(0); 93 expect(sut.profiles).toHaveLength(0);
94 }); 94 });
95 95
96 it('should load services without an ID but with a profile', () => { 96 test('loads services without an ID but with a profile', () => {
97 sut.loadConfig({ 97 sut.loadConfig({
98 profiles: [ 98 profiles: [
99 { 99 {
@@ -112,7 +112,7 @@ describe('loadConfig', () => {
112 expect(sut.services[0].settings.profile).toBe(sut.profiles[0]); 112 expect(sut.services[0].settings.profile).toBe(sut.profiles[0]);
113 }); 113 });
114 114
115 it('should create a profile for a service with an ID but no profile', () => { 115 test('creates a profile for a service with an ID but no profile', () => {
116 sut.loadConfig({ 116 sut.loadConfig({
117 services: [ 117 services: [
118 { 118 {
@@ -128,7 +128,7 @@ describe('loadConfig', () => {
128 ); 128 );
129 }); 129 });
130 130
131 it('should create a profile for a service without an ID or profile', () => { 131 test('creates a profile for a service without an ID or profile', () => {
132 sut.loadConfig({ 132 sut.loadConfig({
133 services: [ 133 services: [
134 { 134 {
@@ -143,7 +143,7 @@ describe('loadConfig', () => {
143 ); 143 );
144 }); 144 });
145 145
146 it('should refuse to load a service without a name', () => { 146 test('refuses to load a service without a name', () => {
147 expect(() => { 147 expect(() => {
148 sut.loadConfig({ 148 sut.loadConfig({
149 services: [ 149 services: [