aboutsummaryrefslogtreecommitdiffstats
path: root/packages/main/src/controllers/__tests__/initNativeTheme.spec.ts
diff options
context:
space:
mode:
authorLibravatar Kristóf Marussy <kristof@marussy.com>2022-01-08 21:36:43 +0100
committerLibravatar Kristóf Marussy <kristof@marussy.com>2022-01-09 19:53:03 +0100
commitd07e7b834831230b53860d0919a68edc2d36193d (patch)
treea1f2a021563ddff54f33341c475fc6c6eb787388 /packages/main/src/controllers/__tests__/initNativeTheme.spec.ts
parentNew configurations based on review comments (WIP) (diff)
downloadsophie-d07e7b834831230b53860d0919a68edc2d36193d.tar.gz
sophie-d07e7b834831230b53860d0919a68edc2d36193d.tar.zst
sophie-d07e7b834831230b53860d0919a68edc2d36193d.zip
build: Eslint fixes for multi-module project
Signed-off-by: Kristóf Marussy <kristof@marussy.com>
Diffstat (limited to 'packages/main/src/controllers/__tests__/initNativeTheme.spec.ts')
-rw-r--r--packages/main/src/controllers/__tests__/initNativeTheme.spec.ts71
1 files changed, 71 insertions, 0 deletions
diff --git a/packages/main/src/controllers/__tests__/initNativeTheme.spec.ts b/packages/main/src/controllers/__tests__/initNativeTheme.spec.ts
new file mode 100644
index 0000000..bd33f48
--- /dev/null
+++ b/packages/main/src/controllers/__tests__/initNativeTheme.spec.ts
@@ -0,0 +1,71 @@
1/*
2 * Copyright (C) 2021-2022 Kristóf Marussy <kristof@marussy.com>
3 *
4 * This file is part of Sophie.
5 *
6 * Sophie is free software: you can redistribute it and/or modify
7 * it under the terms of the GNU Affero General Public License as
8 * published by the Free Software Foundation, version 3.
9 *
10 * This program is distributed in the hope that it will be useful,
11 * but WITHOUT ANY WARRANTY; without even the implied warranty of
12 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
13 * GNU Affero General Public License for more details.
14 *
15 * You should have received a copy of the GNU Affero General Public License
16 * along with this program. If not, see <https://www.gnu.org/licenses/>.
17 *
18 * SPDX-License-Identifier: AGPL-3.0-only
19 */
20
21import { jest } from '@jest/globals';
22import { mocked } from 'jest-mock';
23
24import { createMainStore, MainStore } from '../../stores/MainStore';
25import type Disposer from '../../utils/Disposer';
26
27let shouldUseDarkColors = false;
28
29jest.unstable_mockModule('electron', () => ({
30 nativeTheme: {
31 themeSource: 'system',
32 get shouldUseDarkColors() {
33 return shouldUseDarkColors;
34 },
35 on: jest.fn(),
36 off: jest.fn(),
37 },
38}));
39
40const { nativeTheme } = await import('electron');
41const { default: initNativeTheme } = await import('../initNativeTheme');
42
43let store: MainStore;
44let disposeSut: Disposer;
45
46beforeEach(() => {
47 store = createMainStore();
48 disposeSut = initNativeTheme(store);
49});
50
51it('should register a nativeTheme updated listener', () => {
52 expect(nativeTheme.on).toBeCalledWith('updated', expect.anything());
53});
54
55it('should synchronize themeSource changes to the nativeTheme', () => {
56 store.config.setThemeSource('dark');
57 expect(nativeTheme.themeSource).toBe('dark');
58});
59
60it('should synchronize shouldUseDarkColors changes to the store', () => {
61 const listener = mocked(nativeTheme.on).mock.calls.find(([event]) => event === 'updated')![1];
62 shouldUseDarkColors = true;
63 listener();
64 expect(store.shared.shouldUseDarkColors).toBe(true);
65});
66
67it('should remove the listener on dispose', () => {
68 const listener = mocked(nativeTheme.on).mock.calls.find(([event]) => event === 'updated')![1];
69 disposeSut();
70 expect(nativeTheme.off).toBeCalledWith('updated', listener);
71});