aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-09-27 05:48:52 -0300
committerLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-11-28 04:50:16 -0300
commitc693ea183aaf2ef9009e89046a6a213762441fdc (patch)
tree11663048bc732e71a970714dc612fced7bbfa95a /configure.ac
parentconfigure*: fix typo of "been" (diff)
downloadfirejail-c693ea183aaf2ef9009e89046a6a213762441fdc.tar.gz
firejail-c693ea183aaf2ef9009e89046a6a213762441fdc.tar.zst
firejail-c693ea183aaf2ef9009e89046a6a213762441fdc.zip
configure*: fix trailing comma in HAVE_CONTRIB_INSTALL
Consider the current code: AS_IF([test "x$enable_lts" = "xyes"], [ # ... HAVE_CONTRIB_INSTALL="no", Result of testing the value: $ HAVE_CONTRIB_INSTALL="no", $ printf '%s\n' "$HAVE_CONTRIB_INSTALL" no, $ test "x$HAVE_CONTRIB_INSTALL" = "xno" && echo equal || echo 'not equal' not equal This means that whenever HAVE_LTS is enabled, HAVE_CONTRIB_INSTALL is always considered enabled when testing against "no". But luckily, in the current code the latter variable is only tested against "yes", so nothing should be affected: $ git grep HAVE_CONTRIB_INSTALL | grep -v -e '^configure:' -e '^configure.ac:' Makefile:ifeq ($(HAVE_CONTRIB_INSTALL),yes) config.mk.in:HAVE_CONTRIB_INSTALL=@HAVE_CONTRIB_INSTALL@ Added on commit d1acb31c9 ("compile time: enable LTS", 2021-02-28).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 62702f7bc..250dcba88 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,7 +272,7 @@ AS_IF([test "x$enable_lts" = "xyes"], [
272 HAVE_FILE_TRANSFER="" 272 HAVE_FILE_TRANSFER=""
273 HAVE_SUID="-DHAVE_SUID" 273 HAVE_SUID="-DHAVE_SUID"
274 BUSYBOX_WORKAROUND="no" 274 BUSYBOX_WORKAROUND="no"
275 HAVE_CONTRIB_INSTALL="no", 275 HAVE_CONTRIB_INSTALL="no"
276]) 276])
277 277
278AC_CHECK_HEADER([linux/seccomp.h], [], AC_MSG_ERROR([*** SECCOMP support is not installed (/usr/include/linux/seccomp.h missing) ***])) 278AC_CHECK_HEADER([linux/seccomp.h], [], AC_MSG_ERROR([*** SECCOMP support is not installed (/usr/include/linux/seccomp.h missing) ***]))