aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2021-05-20 01:18:32 -0300
committerLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2021-05-28 18:02:25 -0300
commitbfbed383d8f1aa41f44d1f2716322ed810d294fe (patch)
treec8fc0ee8dfda9a144aaaa3ec76ed287539d2c019 /configure.ac
parentconfigure.ac: run autoupdate to fix autoconf warning (diff)
downloadfirejail-bfbed383d8f1aa41f44d1f2716322ed810d294fe.tar.gz
firejail-bfbed383d8f1aa41f44d1f2716322ed810d294fe.tar.zst
firejail-bfbed383d8f1aa41f44d1f2716322ed810d294fe.zip
configure*: use cat instead of many echoes
For simplicity and increased portability.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac84
1 files changed, 43 insertions, 41 deletions
diff --git a/configure.ac b/configure.ac
index 0a0c2bdac..0eb616355 100644
--- a/configure.ac
+++ b/configure.ac
@@ -311,47 +311,49 @@ src/profstats/Makefile src/man/Makefile src/zsh_completion/Makefile src/bash_com
311src/jailcheck/Makefile]) 311src/jailcheck/Makefile])
312AC_OUTPUT 312AC_OUTPUT
313 313
314echo 314cat <<EOF
315echo "Configuration options:" 315
316echo " prefix: $prefix" 316Configuration options:
317echo " sysconfdir: $sysconfdir" 317 prefix: $prefix
318echo " apparmor: $HAVE_APPARMOR" 318 sysconfdir: $sysconfdir
319echo " SELinux labeling support: $HAVE_SELINUX" 319 apparmor: $HAVE_APPARMOR
320echo " global config: $HAVE_GLOBALCFG" 320 SELinux labeling support: $HAVE_SELINUX
321echo " chroot: $HAVE_CHROOT" 321 global config: $HAVE_GLOBALCFG
322echo " network: $HAVE_NETWORK" 322 chroot: $HAVE_CHROOT
323echo " user namespace: $HAVE_USERNS" 323 network: $HAVE_NETWORK
324echo " X11 sandboxing support: $HAVE_X11" 324 user namespace: $HAVE_USERNS
325echo " whitelisting: $HAVE_WHITELIST" 325 X11 sandboxing support: $HAVE_X11
326echo " private home support: $HAVE_PRIVATE_HOME" 326 whitelisting: $HAVE_WHITELIST
327echo " file transfer support: $HAVE_FILE_TRANSFER" 327 private home support: $HAVE_PRIVATE_HOME
328echo " overlayfs support: $HAVE_OVERLAYFS" 328 file transfer support: $HAVE_FILE_TRANSFER
329echo " DBUS proxy support: $HAVE_DBUSPROXY" 329 overlayfs support: $HAVE_OVERLAYFS
330echo " allow tmpfs as regular user: $HAVE_USERTMPFS" 330 DBUS proxy support: $HAVE_DBUSPROXY
331echo " enable --ouput logging: $HAVE_OUTPUT" 331 allow tmpfs as regular user: $HAVE_USERTMPFS
332echo " Manpage support: $HAVE_MAN" 332 enable --ouput logging: $HAVE_OUTPUT
333echo " firetunnel support: $HAVE_FIRETUNNEL" 333 Manpage support: $HAVE_MAN
334echo " busybox workaround: $BUSYBOX_WORKAROUND" 334 firetunnel support: $HAVE_FIRETUNNEL
335echo " Spectre compiler patch: $HAVE_SPECTRE" 335 busybox workaround: $BUSYBOX_WORKAROUND
336echo " EXTRA_LDFLAGS: $EXTRA_LDFLAGS" 336 Spectre compiler patch: $HAVE_SPECTRE
337echo " EXTRA_CFLAGS: $EXTRA_CFLAGS" 337 EXTRA_LDFLAGS: $EXTRA_LDFLAGS
338echo " fatal warnings: $HAVE_FATAL_WARNINGS" 338 EXTRA_CFLAGS: $EXTRA_CFLAGS
339echo " Gcov instrumentation: $HAVE_GCOV" 339 fatal warnings: $HAVE_FATAL_WARNINGS
340echo " Install contrib scripts: $HAVE_CONTRIB_INSTALL" 340 Gcov instrumentation: $HAVE_GCOV
341echo " Install as a SUID executable: $HAVE_SUID" 341 Install contrib scripts: $HAVE_CONTRIB_INSTALL
342echo " LTS: $HAVE_LTS" 342 Install as a SUID executable: $HAVE_SUID
343echo " Always enforce filters: $HAVE_FORCE_NONEWPRIVS" 343 LTS: $HAVE_LTS
344echo 344 Always enforce filters: $HAVE_FORCE_NONEWPRIVS
345 345
346EOF
346 347
347if test "$HAVE_LTS" = -DHAVE_LTS; then 348if test "$HAVE_LTS" = -DHAVE_LTS; then
348 echo 349 cat <<\EOF
349 echo 350
350 echo "*********************************************************"
351 echo "* Warning: Long-term support (LTS) was enabled! *"
352 echo "* Most compile-time options have bean rewritten! *"
353 echo "*********************************************************"
354 echo
355 echo
356fi
357 351
352*********************************************************
353* Warning: Long-term support (LTS) was enabled! *
354* Most compile-time options have bean rewritten! *
355*********************************************************
356
357
358EOF
359fi