aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar rusty-snake <41237666+rusty-snake@users.noreply.github.com>2021-03-01 12:40:02 +0100
committerLibravatar rusty-snake <41237666+rusty-snake@users.noreply.github.com>2021-03-01 12:40:02 +0100
commitb02d8f91c7fa2ba7c0e0b8a255952d4c8c86fc5e (patch)
treee50efc1e1dcb77e7b250fab9b0a50ca4b2082acf /configure.ac
parentfixes (diff)
downloadfirejail-b02d8f91c7fa2ba7c0e0b8a255952d4c8c86fc5e.tar.gz
firejail-b02d8f91c7fa2ba7c0e0b8a255952d4c8c86fc5e.tar.zst
firejail-b02d8f91c7fa2ba7c0e0b8a255952d4c8c86fc5e.zip
Add ./configure --enable-force-nonewprivs
This will always set 'nonewprivs', 'caps.drop all' and 'nogroups'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 449b8b436..2654a2699 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,6 +228,14 @@ AS_IF([test "x$enable_contrib_install" = "xno"],
228) 228)
229AC_SUBST(HAVE_CONTRIB_INSTALL) 229AC_SUBST(HAVE_CONTRIB_INSTALL)
230 230
231HAVE_FORCE_NONEWPRIVS=""
232AC_ARG_ENABLE([force-nonewprivs],
233 AS_HELP_STRING([--enable-force-nonewprivs], [enable force nonewprivs]))
234AS_IF([test "x$enable_force_nonewprivs" = "xyes"], [
235 HAVE_FORCE_NONEWPRIVS="-DHAVE_FORCE_NONEWPRIVS"
236 AC_SUBST(HAVE_FORCE_NONEWPRIVS)
237])
238
231HAVE_LTS="" 239HAVE_LTS=""
232AC_ARG_ENABLE([lts], 240AC_ARG_ENABLE([lts],
233 AS_HELP_STRING([--enable-lts], [enable long-term support software version (LTS)])) 241 AS_HELP_STRING([--enable-lts], [enable long-term support software version (LTS)]))
@@ -330,6 +338,7 @@ echo " Gcov instrumentation: $HAVE_GCOV"
330echo " Install contrib scripts: $HAVE_CONTRIB_INSTALL" 338echo " Install contrib scripts: $HAVE_CONTRIB_INSTALL"
331echo " Install as a SUID executable: $HAVE_SUID" 339echo " Install as a SUID executable: $HAVE_SUID"
332echo " LTS: $HAVE_LTS" 340echo " LTS: $HAVE_LTS"
341echo " Always enforce filters: $HAVE_FORCE_NONEWPRIVS"
333echo 342echo
334 343
335 344