aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar startx2017 <vradu.startx@yandex.com>2020-09-01 09:54:26 -0400
committerLibravatar startx2017 <vradu.startx@yandex.com>2020-09-01 09:54:26 -0400
commita5c62dfa5955ad91aa6592c0a5443b93f8432bf3 (patch)
tree2b5fecafafbc8fafb1cab44d567385da059b483c /configure.ac
parentshell none: avoid syscalls after seccomp_install_filters (diff)
downloadfirejail-a5c62dfa5955ad91aa6592c0a5443b93f8432bf3.tar.gz
firejail-a5c62dfa5955ad91aa6592c0a5443b93f8432bf3.tar.zst
firejail-a5c62dfa5955ad91aa6592c0a5443b93f8432bf3.zip
removed --disable-seccomp from ./configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index feb0b38a6..0524651fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,14 +76,6 @@ AS_IF([test "x$enable_private_home" != "xno"], [
76 AC_SUBST(HAVE_PRIVATE_HOME) 76 AC_SUBST(HAVE_PRIVATE_HOME)
77]) 77])
78 78
79HAVE_SECCOMP=""
80AC_ARG_ENABLE([seccomp],
81 AS_HELP_STRING([--disable-seccomp], [disable seccomp]))
82AS_IF([test "x$enable_seccomp" != "xno"], [
83 HAVE_SECCOMP="-DHAVE_SECCOMP"
84 AC_SUBST(HAVE_SECCOMP)
85])
86
87HAVE_CHROOT="" 79HAVE_CHROOT=""
88AC_ARG_ENABLE([chroot], 80AC_ARG_ENABLE([chroot],
89 AS_HELP_STRING([--disable-chroot], [disable chroot])) 81 AS_HELP_STRING([--disable-chroot], [disable chroot]))
@@ -196,8 +188,7 @@ AS_IF([test "x$enable_selinux" = "xyes"], [
196# checking pthread library 188# checking pthread library
197AC_CHECK_LIB([pthread], [main], [], AC_MSG_ERROR([*** POSIX thread support not installed ***])) 189AC_CHECK_LIB([pthread], [main], [], AC_MSG_ERROR([*** POSIX thread support not installed ***]))
198AC_CHECK_HEADER(pthread.h,,AC_MSG_ERROR([*** POSIX thread support not installed ***])) 190AC_CHECK_HEADER(pthread.h,,AC_MSG_ERROR([*** POSIX thread support not installed ***]))
199AC_CHECK_HEADER([linux/seccomp.h], HAVE_SECCOMP_H="-DHAVE_SECCOMP_H", HAVE_SECCOMP_H="") 191AC_CHECK_HEADER([linux/seccomp.h],,AC_MSG_ERROR([*** SECCOMP support is not installed (/usr/include/linux/seccomp.h missing) ***]))
200AC_SUBST(HAVE_SECCOMP_H)
201 192
202# set sysconfdir 193# set sysconfdir
203if test "$prefix" = /usr; then 194if test "$prefix" = /usr; then
@@ -214,8 +205,6 @@ echo
214echo "Configuration options:" 205echo "Configuration options:"
215echo " prefix: $prefix" 206echo " prefix: $prefix"
216echo " sysconfdir: $sysconfdir" 207echo " sysconfdir: $sysconfdir"
217echo " seccomp: $HAVE_SECCOMP"
218echo " <linux/seccomp.h>: $HAVE_SECCOMP_H"
219echo " apparmor: $HAVE_APPARMOR" 208echo " apparmor: $HAVE_APPARMOR"
220echo " global config: $HAVE_GLOBALCFG" 209echo " global config: $HAVE_GLOBALCFG"
221echo " chroot: $HAVE_CHROOT" 210echo " chroot: $HAVE_CHROOT"