aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar netblue30 <netblue30@yahoo.com>2015-08-21 08:16:06 -0400
committerLibravatar netblue30 <netblue30@yahoo.com>2015-08-21 08:16:06 -0400
commit9d91a26a154f5b345b46aff539303fae86bd9415 (patch)
treeabe9237133435c6ba96f3d17354d349a54e462c1 /configure.ac
parentMerge pull request #38 from pmillerchip/shell-none-args (diff)
downloadfirejail-9d91a26a154f5b345b46aff539303fae86bd9415.tar.gz
firejail-9d91a26a154f5b345b46aff539303fae86bd9415.tar.zst
firejail-9d91a26a154f5b345b46aff539303fae86bd9415.zip
added --enable-fatal-warnings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8c5a65397..3fa0c933b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,13 @@ AS_IF([test "x$enable_bind" != "xno"], [
33 AC_SUBST(HAVE_BIND) 33 AC_SUBST(HAVE_BIND)
34]) 34])
35 35
36HAVE_FATAL_WARNINGS=""
37AC_ARG_ENABLE([fatal_warnings],
38 AS_HELP_STRING([--enable-fatal-warnings], [-W -Wall -Werror]))
39AS_IF([test "x$enable_fatal_warnings" = "xyes"], [
40 HAVE_FATAL_WARNINGS="-W -Wall -Werror"
41 AC_SUBST(HAVE_FATAL_WARNINGS)
42])
36 43
37# checking pthread library 44# checking pthread library
38AC_CHECK_LIB([pthread], [main], [], AC_MSG_ERROR([*** POSIX thread support not installed ***])) 45AC_CHECK_LIB([pthread], [main], [], AC_MSG_ERROR([*** POSIX thread support not installed ***]))
@@ -49,4 +56,5 @@ echo " seccomp: $HAVE_SECCOMP"
49echo " <linux/seccomp.h>: $HAVE_SECCOMP_H" 56echo " <linux/seccomp.h>: $HAVE_SECCOMP_H"
50echo " chroot: $HAVE_CHROOT" 57echo " chroot: $HAVE_CHROOT"
51echo " bind: $HAVE_BIND" 58echo " bind: $HAVE_BIND"
59echo " fatal warnings: $HAVE_FATAL_WARNINGS"
52echo 60echo