aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar netblue30 <netblue30@protonmail.com>2022-05-25 07:36:42 -0400
committerLibravatar netblue30 <netblue30@protonmail.com>2022-05-25 07:36:42 -0400
commit880f2c98a1dee26228530875fc45d54db68ed1c8 (patch)
treeefeda54d345b7bab410f4dd5e59575391e8c0e17 /configure.ac
parentbuild(deps): bump github/codeql-action from 2.1.10 to 2.1.11 (diff)
downloadfirejail-880f2c98a1dee26228530875fc45d54db68ed1c8.tar.gz
firejail-880f2c98a1dee26228530875fc45d54db68ed1c8.tar.zst
firejail-880f2c98a1dee26228530875fc45d54db68ed1c8.zip
Removed IDS feature from the default build. To enable it, use --enable-ids at compile time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 28e6b7837..8a9afe793 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,14 @@ AS_IF([test "x$enable_sanitizer" != "xno" ],
54 ], [AC_MSG_ERROR([sanitizer not supported: $enable_sanitizer])] 54 ], [AC_MSG_ERROR([sanitizer not supported: $enable_sanitizer])]
55)]) 55)])
56 56
57HAVE_IDS=""
58AC_SUBST([HAVE_IDS])
59AC_ARG_ENABLE([ids],
60 [AS_HELP_STRING([--enable-ids], [enable ids])])
61AS_IF([test "x$enable_ids" = "xyes"], [
62 HAVE_IDS="-DHAVE_IDS"
63])
64
57HAVE_APPARMOR="" 65HAVE_APPARMOR=""
58AC_SUBST([HAVE_APPARMOR]) 66AC_SUBST([HAVE_APPARMOR])
59AC_ARG_ENABLE([apparmor], 67AC_ARG_ENABLE([apparmor],
@@ -249,6 +257,7 @@ AC_ARG_ENABLE([lts],
249 [AS_HELP_STRING([--enable-lts], [enable long-term support software version (LTS)])]) 257 [AS_HELP_STRING([--enable-lts], [enable long-term support software version (LTS)])])
250AS_IF([test "x$enable_lts" = "xyes"], [ 258AS_IF([test "x$enable_lts" = "xyes"], [
251 HAVE_LTS="-DHAVE_LTS" 259 HAVE_LTS="-DHAVE_LTS"
260 HAVE_IDS=""
252 HAVE_DBUSPROXY="" 261 HAVE_DBUSPROXY=""
253 HAVE_OVERLAYFS="" 262 HAVE_OVERLAYFS=""
254 HAVE_OUTPUT="" 263 HAVE_OUTPUT=""
@@ -300,6 +309,7 @@ Configuration options:
300 allow tmpfs as regular user: $HAVE_USERTMPFS 309 allow tmpfs as regular user: $HAVE_USERTMPFS
301 enable --ouput logging: $HAVE_OUTPUT 310 enable --ouput logging: $HAVE_OUTPUT
302 Manpage support: $HAVE_MAN 311 Manpage support: $HAVE_MAN
312 IDS support: $HAVE_IDS
303 firetunnel support: $HAVE_FIRETUNNEL 313 firetunnel support: $HAVE_FIRETUNNEL
304 busybox workaround: $BUSYBOX_WORKAROUND 314 busybox workaround: $BUSYBOX_WORKAROUND
305 Spectre compiler patch: $HAVE_SPECTRE 315 Spectre compiler patch: $HAVE_SPECTRE