aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2021-11-01 14:10:28 -0300
committerLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2021-11-25 11:32:08 -0300
commit6d42e13a46b970c7197e1b70f6440ada1f8ec410 (patch)
tree799170ae63f7a6323cc674cd7025f3ad28f29402 /configure.ac
parentconfigure*: Remove redundant AC_SUBST calls near HAVE_LTS (diff)
downloadfirejail-6d42e13a46b970c7197e1b70f6440ada1f8ec410.tar.gz
firejail-6d42e13a46b970c7197e1b70f6440ada1f8ec410.tar.zst
firejail-6d42e13a46b970c7197e1b70f6440ada1f8ec410.zip
build: Normalize HAVE_SUID
See commit 15d793838 ("Try to fix #2310 -- Can't create run directory without suid-root", 2021-05-13) / PR #4273. It is the only "HAVE_" option whose value is set by if/else on a makefile. Also, it is set in different places to either "yes", "no", blank or "-DHAVE_SUID". Set the value only on configure.ac and only to either blank or to "-DHAVE_SUID". Misc: The `ifeq ($(HAVE_SUID),-DHAVE_SUID)` comparison that this adds is based on the existing `ifeq ($(HAVE_APPARMOR),-DHAVE_APPARMOR)` comparison on Makefile.in.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ace02dcb6..2870148cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -191,10 +191,9 @@ HAVE_SUID=""
191AC_SUBST([HAVE_SUID]) 191AC_SUBST([HAVE_SUID])
192AC_ARG_ENABLE([suid], 192AC_ARG_ENABLE([suid],
193 [AS_HELP_STRING([--disable-suid], [install as a non-SUID executable])]) 193 [AS_HELP_STRING([--disable-suid], [install as a non-SUID executable])])
194AS_IF([test "x$enable_suid" = "xno"], 194AS_IF([test "x$enable_suid" != "xno"], [
195 [HAVE_SUID="no"], 195 HAVE_SUID="-DHAVE_SUID"
196 [HAVE_SUID="yes"] 196])
197)
198 197
199HAVE_FATAL_WARNINGS="" 198HAVE_FATAL_WARNINGS=""
200AC_SUBST([HAVE_FATAL_WARNINGS]) 199AC_SUBST([HAVE_FATAL_WARNINGS])
@@ -257,7 +256,7 @@ AS_IF([test "x$enable_lts" = "xyes"], [
257 HAVE_USERNS="" 256 HAVE_USERNS=""
258 HAVE_X11="" 257 HAVE_X11=""
259 HAVE_FILE_TRANSFER="" 258 HAVE_FILE_TRANSFER=""
260 HAVE_SUID="yes" 259 HAVE_SUID="-DHAVE_SUID"
261 BUSYBOX_WORKAROUND="no" 260 BUSYBOX_WORKAROUND="no"
262 HAVE_CONTRIB_INSTALL="no", 261 HAVE_CONTRIB_INSTALL="no",
263]) 262])