aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-11-30 01:11:48 -0300
committerLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-12-03 07:52:41 -0300
commit671c3f24923d53bae96c8ef4989c250a5ce787c3 (patch)
tree171900a03c4da7962f382304e26bd7cee312e8a6 /configure.ac
parentconfigure*: print CC and CFLAGS (diff)
downloadfirejail-671c3f24923d53bae96c8ef4989c250a5ce787c3.tar.gz
firejail-671c3f24923d53bae96c8ef4989c250a5ce787c3.tar.zst
firejail-671c3f24923d53bae96c8ef4989c250a5ce787c3.zip
build: actually set LDFLAGS and LIBS in makefiles
Both variables are used inside on src/prog.mk and src/so.mk, but they are not currently defined in any makefile, so their values cannot be substituted by ./configure. This means that the variables can be set when running make (such as with `make LDFLAGS=-Lfoo`), but changing them in configure.ac has no effect. The same applies when trying to set them when running ./configure (such as with `./configure LDFLAGS=-Lfoo`).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 49ad265e3..416d79682 100644
--- a/configure.ac
+++ b/configure.ac
@@ -293,8 +293,10 @@ cat <<EOF
293Compile options: 293Compile options:
294 CC: $CC 294 CC: $CC
295 CFLAGS: $CFLAGS 295 CFLAGS: $CFLAGS
296 LDFLAGS: $LDFLAGS
296 EXTRA_CFLAGS: $EXTRA_CFLAGS 297 EXTRA_CFLAGS: $EXTRA_CFLAGS
297 EXTRA_LDFLAGS: $EXTRA_LDFLAGS 298 EXTRA_LDFLAGS: $EXTRA_LDFLAGS
299 LIBS: $LIBS
298 fatal warnings: $HAVE_FATAL_WARNINGS 300 fatal warnings: $HAVE_FATAL_WARNINGS
299 gcov instrumentation: $HAVE_GCOV 301 gcov instrumentation: $HAVE_GCOV
300 install as a SUID executable: $HAVE_SUID 302 install as a SUID executable: $HAVE_SUID