aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar netblue30 <netblue30@yahoo.com>2016-11-07 12:44:08 -0500
committerLibravatar netblue30 <netblue30@yahoo.com>2016-11-07 12:44:08 -0500
commit66a476419d301ca7eb879d205e394a0a8c21e598 (patch)
tree06bb478fe68f81ce2db5374b0f3ed96ccbdb9b51 /configure.ac
parentprofiles (diff)
downloadfirejail-66a476419d301ca7eb879d205e394a0a8c21e598.tar.gz
firejail-66a476419d301ca7eb879d205e394a0a8c21e598.tar.zst
firejail-66a476419d301ca7eb879d205e394a0a8c21e598.zip
gcov support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9e7680d7d..e05c023f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ AS_IF([test "x$enable_apparmor" = "xyes"], [
22 [Couldn't find sys/apparmor.h... please install apparmor user space library and development files] )]) 22 [Couldn't find sys/apparmor.h... please install apparmor user space library and development files] )])
23]) 23])
24AS_IF([test "x$enable_apparmor" = "xyes"], [ 24AS_IF([test "x$enable_apparmor" = "xyes"], [
25 EXTRA_LDFLAGS="-lapparmor" 25 EXTRA_LDFLAGS+="-lapparmor "
26]) 26])
27AC_SUBST([EXTRA_LDFLAGS]) 27AC_SUBST([EXTRA_LDFLAGS])
28 28
@@ -136,6 +136,16 @@ AS_IF([test "x$enable_busybox_workaround" = "xyes"], [
136]) 136])
137 137
138 138
139HAVE_GCOV=""
140AC_ARG_ENABLE([gcov],
141 AS_HELP_STRING([--enable-gcov], [Gcov instrumentation]))
142AS_IF([test "x$enable_gcov" = "xyes"], [
143 HAVE_GCOV="--coverage "
144 EXTRA_LDFLAGS+="-lgcov --coverage "
145 AC_SUBST(HAVE_GCOV)
146])
147
148
139 149
140# checking pthread library 150# checking pthread library
141AC_CHECK_LIB([pthread], [main], [], AC_MSG_ERROR([*** POSIX thread support not installed ***])) 151AC_CHECK_LIB([pthread], [main], [], AC_MSG_ERROR([*** POSIX thread support not installed ***]))
@@ -170,7 +180,8 @@ echo " file transfer support: $HAVE_FILE_TRANSFER"
170echo " overlayfs support: $HAVE_OVERLAYFS" 180echo " overlayfs support: $HAVE_OVERLAYFS"
171echo " fatal warnings: $HAVE_FATAL_WARNINGS" 181echo " fatal warnings: $HAVE_FATAL_WARNINGS"
172echo " busybox workaround: $BUSYBOX_WORKAROUND" 182echo " busybox workaround: $BUSYBOX_WORKAROUND"
173printf " EXTRA_LDFLAGS: $EXTRA_LDFLAGS" 183echo " EXTRA_LDFLAGS: $EXTRA_LDFLAGS"
184echo " Gcov instrumentation: $HAVE_GCOV"
174echo 185echo
175 186
176 187