aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-12-06 06:42:54 -0300
committerLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2024-01-17 10:33:57 -0300
commit5b1ce32bbced20b01be2dcea4ecca510a7194b75 (patch)
treeb914170c00fec607ab43f09d3eaf0fc5bd0a6296 /configure.ac
parentbuild(deps): bump github/codeql-action from 3.22.12 to 3.23.0 (diff)
downloadfirejail-5b1ce32bbced20b01be2dcea4ecca510a7194b75.tar.gz
firejail-5b1ce32bbced20b01be2dcea4ecca510a7194b75.tar.zst
firejail-5b1ce32bbced20b01be2dcea4ecca510a7194b75.zip
build: use CPPFLAGS instead of INCLUDE in compile targets
With this, CFLAGS and CPPFLAGS are used when compiling and LDFLAGS when linking, just like in the built-in GNU make rules. From `make -p`: COMPILE.c = $(CC) $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -c LINK.c = $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(TARGET_ARCH) LINK.o = $(CC) $(LDFLAGS) $(TARGET_ARCH) Note: It is unclear where the `INCLUDE` variable comes from; it is not documented in autoconf nor GNU make and automake (which itself is not used in this repository) only mentions `INCLUDES`: `INCLUDES` This does the same job as `AM_CPPFLAGS` (or any per-target `_CPPFLAGS` variable if it is used). It is an older name for the same functionality. This variable is deprecated; we suggest using `AM_CPPFLAGS` and per-target `_CPPFLAGS` instead. Environment: automake 1.16.5-2 and GNU make 4.4.1 on Artix Linux. See also commit 671c3f249 ("build: actually set LDFLAGS and LIBS in makefiles", 2022-11-30) / PR #5504.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fc99820de..d3b05d839 100644
--- a/configure.ac
+++ b/configure.ac
@@ -276,6 +276,7 @@ cat <<EOF
276Compile options: 276Compile options:
277 CC: $CC 277 CC: $CC
278 CFLAGS: $CFLAGS 278 CFLAGS: $CFLAGS
279 CPPFLAGS: $CPPFLAGS
279 LDFLAGS: $LDFLAGS 280 LDFLAGS: $LDFLAGS
280 EXTRA_CFLAGS: $EXTRA_CFLAGS 281 EXTRA_CFLAGS: $EXTRA_CFLAGS
281 EXTRA_LDFLAGS: $EXTRA_LDFLAGS 282 EXTRA_LDFLAGS: $EXTRA_LDFLAGS