aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar netblue30 <netblue30@protonmail.com>2023-10-24 12:43:46 -0400
committerLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2023-11-07 17:55:13 -0300
commit13b2c566df883269b55f77757bb50a5d2890ec20 (patch)
tree5c7ccc9d00886b93c4429a91671161fa6464f1f9 /configure.ac
parentcleanup (diff)
downloadfirejail-13b2c566df883269b55f77757bb50a5d2890ec20.tar.gz
firejail-13b2c566df883269b55f77757bb50a5d2890ec20.tar.zst
firejail-13b2c566df883269b55f77757bb50a5d2890ec20.zip
feature: add Landlock support
Based on 5315 by ChrysoliteAzalea. It is based on the same underlying structure, but with a lot of refactoring/simplification and with bugfixes and improvements. Co-authored-by: Kelvin M. Klann <kmk3.code@protonmail.com> Co-authored-by: Азалия Смарагдова <charming.flurry@yandex.ru>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 93de61b95..bd80150ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,16 @@ AS_IF([test "x$enable_selinux" = "xyes"], [
81 LIBS="$LIBS -lselinux" 81 LIBS="$LIBS -lselinux"
82]) 82])
83 83
84HAVE_LANDLOCK=""
85AC_SUBST([HAVE_LANDLOCK])
86AC_ARG_ENABLE([landlock],
87 [AS_HELP_STRING([--enable-landlock], [Landlock self-restriction support])])
88AS_IF([test "x$enable_landlock" != "xno"], [
89 AC_CHECK_HEADER([linux/landlock.h],
90 [HAVE_LANDLOCK="-DHAVE_LANDLOCK"],
91 [AC_MSG_WARN([header not found: linux/landlock.h, building without Landlock support])])
92])
93
84AC_SUBST([EXTRA_CFLAGS]) 94AC_SUBST([EXTRA_CFLAGS])
85AC_SUBST([EXTRA_LDFLAGS]) 95AC_SUBST([EXTRA_LDFLAGS])
86 96
@@ -264,6 +274,7 @@ AC_ARG_ENABLE([lts],
264 [AS_HELP_STRING([--enable-lts], [enable long-term support software version (LTS)])]) 274 [AS_HELP_STRING([--enable-lts], [enable long-term support software version (LTS)])])
265AS_IF([test "x$enable_lts" = "xyes"], [ 275AS_IF([test "x$enable_lts" = "xyes"], [
266 HAVE_LTS="-DHAVE_LTS" 276 HAVE_LTS="-DHAVE_LTS"
277 HAVE_LANDLOCK=""
267 HAVE_IDS="" 278 HAVE_IDS=""
268 HAVE_DBUSPROXY="" 279 HAVE_DBUSPROXY=""
269 HAVE_OVERLAYFS="" 280 HAVE_OVERLAYFS=""
@@ -324,6 +335,7 @@ Features:
324 firetunnel support: $HAVE_FIRETUNNEL 335 firetunnel support: $HAVE_FIRETUNNEL
325 global config: $HAVE_GLOBALCFG 336 global config: $HAVE_GLOBALCFG
326 IDS support: $HAVE_IDS 337 IDS support: $HAVE_IDS
338 Landlock support: $HAVE_LANDLOCK
327 LTS: $HAVE_LTS 339 LTS: $HAVE_LTS
328 manpage support: $HAVE_MAN 340 manpage support: $HAVE_MAN
329 network: $HAVE_NETWORK 341 network: $HAVE_NETWORK