aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-09-27 06:03:05 -0300
committerLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-11-28 04:55:01 -0300
commit11daf6eaa7f54d2714225921fe6a46d28dabb603 (patch)
tree9e4030ac2fbd519ecae15eae5e863bedb388f9c2 /configure.ac
parentconfigure*: wrap long AS_HELP_STRING line (sanitizer) (diff)
downloadfirejail-11daf6eaa7f54d2714225921fe6a46d28dabb603.tar.gz
firejail-11daf6eaa7f54d2714225921fe6a46d28dabb603.tar.zst
firejail-11daf6eaa7f54d2714225921fe6a46d28dabb603.zip
configure*: fix quotes/parens alignment (sanitizer)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 774fd57a1..9e2061211 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,12 +49,12 @@ AC_ARG_ENABLE([sanitizer],
49 [enable a compiler-based sanitizer (debug)])], 49 [enable a compiler-based sanitizer (debug)])],
50 [], 50 [],
51 [enable_sanitizer=no]) 51 [enable_sanitizer=no])
52AS_IF([test "x$enable_sanitizer" != "xno" ], 52AS_IF([test "x$enable_sanitizer" != "xno" ], [
53 [AX_CHECK_COMPILE_FLAG([-fsanitize=$enable_sanitizer], [ 53 AX_CHECK_COMPILE_FLAG([-fsanitize=$enable_sanitizer], [
54 EXTRA_CFLAGS="$EXTRA_CFLAGS -fsanitize=$enable_sanitizer -fno-omit-frame-pointer" 54 EXTRA_CFLAGS="$EXTRA_CFLAGS -fsanitize=$enable_sanitizer -fno-omit-frame-pointer"
55 EXTRA_LDFLAGS="$EXTRA_LDFLAGS -fsanitize=$enable_sanitizer" 55 EXTRA_LDFLAGS="$EXTRA_LDFLAGS -fsanitize=$enable_sanitizer"
56 ], [AC_MSG_ERROR([sanitizer not supported: $enable_sanitizer])] 56 ], [AC_MSG_ERROR([sanitizer not supported: $enable_sanitizer])])
57)]) 57])
58 58
59HAVE_IDS="" 59HAVE_IDS=""
60AC_SUBST([HAVE_IDS]) 60AC_SUBST([HAVE_IDS])