aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2024-03-20 07:28:50 +0000
committerLibravatar GitHub <noreply@github.com>2024-03-20 07:28:50 +0000
commit0da23da653c273874a3efa8b57db264ab2dadfea (patch)
tree4cbb94283e404f9b538628f5c6fceb2e07be0884 /configure.ac
parentRename etc/session-desktop.profile to etc/profile-m-z/session-desktop.profile (diff)
downloadfirejail-0da23da653c273874a3efa8b57db264ab2dadfea.tar.gz
firejail-0da23da653c273874a3efa8b57db264ab2dadfea.tar.zst
firejail-0da23da653c273874a3efa8b57db264ab2dadfea.zip
build: fix "warning: "_FORTIFY_SOURCE" redefined" (#6283)
The warning is being produced on Arch since pacman 6.1, which changed `-D_FORTIFY_SOURCE=2` to `-D_FORTIFY_SOURCE=3` in CFLAGS in makepkg.conf: $ pacman -Q gcc pacman gcc 13.2.1-5 pacman 6.1.0-3 $ makepkg [...] make -C src/lib gcc [...] -D_FORTIFY_SOURCE=2 [...] -Wp,-D_FORTIFY_SOURCE=3 [...] -c ../../src/lib/common.c -o ../../src/lib/common.o <command-line>: warning: "_FORTIFY_SOURCE" redefined <command-line>: note: this is the location of the previous definition To fix this, only add `-D_FORTIFY_SOURCE` to EXTRA_CFLAGS if it does not cause any warnings with CFLAGS and CPPFLAGS during compilation. The effect remains the same: The build system still defines the macro by default (if there are no warnings) and the user/distribution can still override it through CFLAGS/CPPFLAGS. Fixes #6282. Reported-by: @glitsj16
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2762c2ef0..73bd334f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,10 @@ AX_CHECK_COMPILE_FLAG([-MMD -MP], [
30 DEPS_CFLAGS="$DEPS_CFLAGS -MMD -MP" 30 DEPS_CFLAGS="$DEPS_CFLAGS -MMD -MP"
31]) 31])
32 32
33AX_CHECK_COMPILE_FLAG([-D_FORTIFY_SOURCE=2], [
34 EXTRA_CFLAGS="$EXTRA_CFLAGS -D_FORTIFY_SOURCE=2"
35], [], [$CFLAGS $CPPFLAGS -Werror])
36
33HAVE_SPECTRE="no" 37HAVE_SPECTRE="no"
34AX_CHECK_COMPILE_FLAG([-mindirect-branch=thunk], [ 38AX_CHECK_COMPILE_FLAG([-mindirect-branch=thunk], [
35 HAVE_SPECTRE="yes" 39 HAVE_SPECTRE="yes"