aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar startx2017 <vradu.startx@yandex.com>2018-09-06 08:56:58 -0400
committerLibravatar startx2017 <vradu.startx@yandex.com>2018-09-06 08:56:58 -0400
commit0adf8f882ccd6f306f9d76ae2b599ab41bee6471 (patch)
tree608321b0cb8f7eaee5d03b968f8b8a3f4ae89099 /configure.ac
parentfinal cleanup (diff)
downloadfirejail-0adf8f882ccd6f306f9d76ae2b599ab41bee6471.tar.gz
firejail-0adf8f882ccd6f306f9d76ae2b599ab41bee6471.tar.zst
firejail-0adf8f882ccd6f306f9d76ae2b599ab41bee6471.zip
final cleanup
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index a6bc44318..1660c2011 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,8 +9,6 @@ AC_PROG_INSTALL
9AC_PROG_RANLIB 9AC_PROG_RANLIB
10 10
11# LTS marker 11# LTS marker
12EXTRA_CFLAGS+=" -DLTS "
13
14 12
15HAVE_SPECTRE="no" 13HAVE_SPECTRE="no"
16AC_MSG_CHECKING(for Spectre mitigation support in gcc or clang compiler) 14AC_MSG_CHECKING(for Spectre mitigation support in gcc or clang compiler)
@@ -63,14 +61,6 @@ AS_IF([test "x$enable_seccomp" != "xno"], [
63 AC_SUBST(HAVE_SECCOMP) 61 AC_SUBST(HAVE_SECCOMP)
64]) 62])
65 63
66HAVE_BIND=""
67AC_ARG_ENABLE([bind],
68 AS_HELP_STRING([--disable-bind], [disable bind]))
69AS_IF([test "x$enable_bind" != "xno"], [
70 HAVE_BIND="-DHAVE_BIND"
71 AC_SUBST(HAVE_BIND)
72])
73
74HAVE_GLOBALCFG="" 64HAVE_GLOBALCFG=""
75AC_ARG_ENABLE([globalcfg], 65AC_ARG_ENABLE([globalcfg],
76 AS_HELP_STRING([--disable-globalcfg], [if the global config file firejail.cfg is not present, continue the program using defaults])) 66 AS_HELP_STRING([--disable-globalcfg], [if the global config file firejail.cfg is not present, continue the program using defaults]))
@@ -161,7 +151,6 @@ echo " seccomp: $HAVE_SECCOMP"
161echo " <linux/seccomp.h>: $HAVE_SECCOMP_H" 151echo " <linux/seccomp.h>: $HAVE_SECCOMP_H"
162echo " apparmor: $HAVE_APPARMOR" 152echo " apparmor: $HAVE_APPARMOR"
163echo " global config: $HAVE_GLOBALCFG" 153echo " global config: $HAVE_GLOBALCFG"
164echo " bind: $HAVE_BIND"
165echo " network: $HAVE_NETWORK" 154echo " network: $HAVE_NETWORK"
166echo " user namespace: $HAVE_USERNS" 155echo " user namespace: $HAVE_USERNS"
167echo " whitelisting: $HAVE_WHITELIST" 156echo " whitelisting: $HAVE_WHITELIST"