aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar Reiner Herrmann <reiner@reiner-h.de>2021-05-23 11:43:59 +0200
committerLibravatar Reiner Herrmann <reiner@reiner-h.de>2021-05-23 11:48:27 +0200
commit07b85f39afd6a22e65925dceabbf320ca6fb335d (patch)
tree9f19a367423ebc6003d1e5f3554f98db7a74b486 /configure.ac
parentMerge pull request #4293 from kmk3/configure-fix-portability (diff)
downloadfirejail-07b85f39afd6a22e65925dceabbf320ca6fb335d.tar.gz
firejail-07b85f39afd6a22e65925dceabbf320ca6fb335d.tar.zst
firejail-07b85f39afd6a22e65925dceabbf320ca6fb335d.zip
CI: build with GCC 11
this fixes a new false positive memory leak (#4297), but unfortunately opens a few new false positives (#4274). therefore let it ignore memleak checks for now, until the detection is a bit more stable in GCC. Fixes: #4274, #4297
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 606f4ef7e..4af69766d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,9 +40,9 @@ AX_CHECK_COMPILE_FLAG(
40) 40)
41 41
42AC_ARG_ENABLE([analyzer], 42AC_ARG_ENABLE([analyzer],
43 AS_HELP_STRING([--enable-analyzer], [enable GCC 10 static analyzer])) 43 AS_HELP_STRING([--enable-analyzer], [enable GCC static analyzer]))
44AS_IF([test "x$enable_analyzer" = "xyes"], [ 44AS_IF([test "x$enable_analyzer" = "xyes"], [
45 EXTRA_CFLAGS="$EXTRA_CFLAGS -fanalyzer" 45 EXTRA_CFLAGS="$EXTRA_CFLAGS -fanalyzer -Wno-analyzer-malloc-leak"
46]) 46])
47 47
48HAVE_APPARMOR="" 48HAVE_APPARMOR=""