aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-05-10 15:47:44 -0300
committerLibravatar Kelvin M. Klann <kmk3.code@protonmail.com>2022-06-30 05:30:14 -0300
commit011d84b462a78703b9b939cb5e48b4cc75ebe015 (patch)
treefe2ad82e289323a7749191a6e8f719b011e2b937 /configure.ac
parentTransmission fixes: drop private-lib (#5213) (diff)
downloadfirejail-011d84b462a78703b9b939cb5e48b4cc75ebe015.tar.gz
firejail-011d84b462a78703b9b939cb5e48b4cc75ebe015.tar.zst
firejail-011d84b462a78703b9b939cb5e48b4cc75ebe015.zip
build: reduce autoconf input files from 32 to 2
Configure summary: autoconf essentially only parses configure.ac and generates the configure script (that is, the "./configure" shell script). The latter is what actually checks what is available on the system and internally sets the value of the output variables. It then, for every filename foo in AC_CONFIG_FILES (and for every output variable name BAR in AC_SUBST), reads foo.in, replaces every occurrence of `@BAR@` with the value of the shell variable `$BAR` and generates the file foo from the result. After this, configure is finished and `make` could be executed to start the build. Now that (as of #5140) all output variables are only defined on config.mk.in and on config.sh.in, there is no need to generate any makefile nor any other mkfile or shell script at configure time. So rename every "Makefile.in" to "Makefile", mkdeb.sh.in to mkdeb.sh, src/common.mk.in to src/common.mk and leave just config.mk and config.sh as the files to be generated at configure time. This allows editing and committing all makefiles directly, without potentially having to run ./configure in between. Commands used to rename the makefiles: $ git ls-files -z -- '*Makefile.in' | xargs -0 -I '{}' sh -c \ "git mv '{}' \"\$(dirname '{}')/Makefile\"" Additionally, from my (rudimentary) testing, this commit reduces the time it takes to run ./configure by about 20~25% compared to commit 72ece92ea ("Transmission fixes: drop private-lib (#5213)", 2022-06-22). Environment: dash 0.5.11.5-1, gcc 12.1.0-2, Artix Linux, ext4 on an HDD. Commands used for benchmarking each commit: $ : >time_configure && ./configure && make distclean && for i in $(seq 1 10); do { time -p ./configure; } 2>>time_configure; done $ grep real time_configure | awk '{ total += $2 } END { print total/NR }'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 1 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index 53de0eb1d..8a488ff43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,40 +282,7 @@ if test "$prefix" = /usr; then
282 test "$sysconfdir" = '${prefix}/etc' && sysconfdir="/etc" 282 test "$sysconfdir" = '${prefix}/etc' && sysconfdir="/etc"
283fi 283fi
284 284
285AC_CONFIG_FILES([mkdeb.sh], [chmod +x mkdeb.sh]) 285AC_CONFIG_FILES([config.mk config.sh])
286AC_CONFIG_FILES([
287Makefile
288config.mk
289config.sh
290src/bash_completion/Makefile
291src/common.mk
292src/fbuilder/Makefile
293src/fcopy/Makefile
294src/fids/Makefile
295src/firecfg/Makefile
296src/firejail/Makefile
297src/firemon/Makefile
298src/fldd/Makefile
299src/fnet/Makefile
300src/fnetfilter/Makefile
301src/fnettrace-dns/Makefile
302src/fnettrace-sni/Makefile
303src/fnettrace/Makefile
304src/fsec-optimize/Makefile
305src/fsec-print/Makefile
306src/fseccomp/Makefile
307src/ftee/Makefile
308src/fzenity/Makefile
309src/jailcheck/Makefile
310src/lib/Makefile
311src/libpostexecseccomp/Makefile
312src/libtrace/Makefile
313src/libtracelog/Makefile
314src/man/Makefile
315src/profstats/Makefile
316src/zsh_completion/Makefile
317test/Makefile
318])
319AC_OUTPUT 286AC_OUTPUT
320 287
321cat <<EOF 288cat <<EOF