aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index da65f08..4f749a5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,15 +1,23 @@
1[tool.poetry] 1[tool.poetry]
2name = "beancount-extras-kris7t" 2name = "beancount-extras-kris7t"
3version = "0.1.0" 3version = "0.1.0"
4description = "Miscellaneous plugins, importers and price sources for Beancount" 4description = "Miscellaneous plugins and importers for Beancount"
5authors = ["Kristóf Marussy <kristof@marussy.com>"] 5authors = ["Kristóf Marussy <kristof@marussy.com>"]
6license = "GPL-2.0-only" 6license = "GPL-2.0-only"
7 7
8[tool.poetry.dependencies] 8[tool.poetry.dependencies]
9python = "^3.9" 9python = "^3.9"
10beancount = { path = "beancount", develop = true } 10beancount = { path = "beancount", develop = true }
11"pdfminer.six" = "^20201018"
12requests = { version = "^2.25.1", optional = true }
13SecretStorage = { version = "^3.3.0", optional = true }
11 14
12[tool.poetry.dev-dependencies] 15[tool.poetry.dev-dependencies]
16flake8 = "^3.8.4"
17mypy = "^0.800"
18
19[tool.poetry.extras]
20transferwise = ["requests", "SecretStorage"]
13 21
14[build-system] 22[build-system]
15requires = ["poetry>=0.12"] 23requires = ["poetry>=0.12"]