aboutsummaryrefslogtreecommitdiffstats
path: root/swaynag/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swaynag/meson.build')
-rw-r--r--swaynag/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/swaynag/meson.build b/swaynag/meson.build
new file mode 100644
index 00000000..6492e4dc
--- /dev/null
+++ b/swaynag/meson.build
@@ -0,0 +1,20 @@
1executable(
2 'swaynag', [
3 'main.c',
4 'nagbar.c',
5 'render.c',
6 ],
7 include_directories: [sway_inc],
8 dependencies: [
9 cairo,
10 client_protos,
11 gdk_pixbuf,
12 pango,
13 pangocairo,
14 wayland_client,
15 wayland_cursor,
16 wlroots,
17 ],
18 link_with: [lib_sway_common, lib_sway_client],
19 install: true
20)