summaryrefslogtreecommitdiffstats
path: root/swaynag/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swaynag/meson.build')
-rw-r--r--swaynag/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/swaynag/meson.build b/swaynag/meson.build
new file mode 100644
index 00000000..2ba3ed95
--- /dev/null
+++ b/swaynag/meson.build
@@ -0,0 +1,23 @@
1executable(
2 'swaynag', [
3 'config.c',
4 'main.c',
5 'render.c',
6 'swaynag.c',
7 'types.c',
8 ],
9 include_directories: [sway_inc],
10 dependencies: [
11 cairo,
12 client_protos,
13 gdk_pixbuf,
14 math,
15 pango,
16 pangocairo,
17 wayland_client,
18 wayland_cursor,
19 wlroots,
20 ],
21 link_with: [lib_sway_common, lib_sway_client],
22 install: true
23)