summaryrefslogtreecommitdiffstats
path: root/swaymsg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'swaymsg/CMakeLists.txt')
-rw-r--r--swaymsg/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/swaymsg/CMakeLists.txt b/swaymsg/CMakeLists.txt
new file mode 100644
index 00000000..79af0f3e
--- /dev/null
+++ b/swaymsg/CMakeLists.txt
@@ -0,0 +1,16 @@
1project(swaymsg)
2
3set(CMAKE_CURRENT_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/../bin/)
4
5FILE(GLOB sources ${PROJECT_SOURCE_DIR}/*.c)
6FILE(GLOB common ${PROJECT_SOURCE_DIR}/../common/*.c)
7
8add_executable(swaymsg
9 ${sources}
10 ${common}
11)
12
13install(
14 TARGETS swaymsg
15 RUNTIME DESTINATION bin
16 COMPONENT runtime)