aboutsummaryrefslogtreecommitdiffstats
path: root/swaybg/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swaybg/meson.build')
-rw-r--r--swaybg/meson.build36
1 files changed, 16 insertions, 20 deletions
diff --git a/swaybg/meson.build b/swaybg/meson.build
index 7f5d6bd1..5e10f3c7 100644
--- a/swaybg/meson.build
+++ b/swaybg/meson.build
@@ -1,22 +1,18 @@
1deps = [
2 cairo,
3 jsonc,
4 math,
5 pango,
6 pangocairo,
7 sway_protos,
8 wayland_client,
9]
10
11if gdk_pixbuf.found()
12 deps += [gdk_pixbuf]
13endif
14
15executable( 1executable(
16 'swaybg', 2 'swaybg',
17 'main.c', 3 'main.c',
18 include_directories: [sway_inc], 4 include_directories: [sway_inc],
19 dependencies: deps, 5 dependencies: [
20 link_with: [lib_sway_common, lib_sway_client], 6 cairo,
21 install: true 7 gdk_pixbuf,
8 jsonc,
9 math,
10 pango,
11 pangocairo,
12 sway_protos,
13 wayland_client,
14 wlroots,
15 ],
16 link_with: [lib_sway_common, lib_sway_client],
17 install: true
22) 18)