aboutsummaryrefslogtreecommitdiffstats
path: root/swaybg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'swaybg/CMakeLists.txt')
-rw-r--r--swaybg/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/swaybg/CMakeLists.txt b/swaybg/CMakeLists.txt
index 4dc961ff..68098370 100644
--- a/swaybg/CMakeLists.txt
+++ b/swaybg/CMakeLists.txt
@@ -3,7 +3,6 @@ include_directories(
3 ${WAYLAND_CLIENT_INCLUDE_DIR} 3 ${WAYLAND_CLIENT_INCLUDE_DIR}
4 ${CAIRO_INCLUDE_DIRS} 4 ${CAIRO_INCLUDE_DIRS}
5 ${PANGO_INCLUDE_DIRS} 5 ${PANGO_INCLUDE_DIRS}
6 ${GDK_PIXBUF_INCLUDE_DIRS}
7) 6)
8 7
9add_executable(swaybg 8add_executable(swaybg
@@ -17,10 +16,18 @@ target_link_libraries(swaybg
17 ${WAYLAND_CURSOR_LIBRARIES} 16 ${WAYLAND_CURSOR_LIBRARIES}
18 ${CAIRO_LIBRARIES} 17 ${CAIRO_LIBRARIES}
19 ${PANGO_LIBRARIES} 18 ${PANGO_LIBRARIES}
20 ${GDK_PIXBUF_LIBRARIES}
21 m 19 m
22) 20)
23 21
22if (WITH_GDK_PIXBUF)
23 include_directories(
24 ${GDK_PIXBUF_INCLUDE_DIRS}
25 )
26 target_link_libraries(swaybg
27 ${GDK_PIXBUF_LIBRARIES}
28 )
29endif()
30
24install( 31install(
25 TARGETS swaybg 32 TARGETS swaybg
26 RUNTIME 33 RUNTIME