aboutsummaryrefslogtreecommitdiffstats
path: root/swaybar/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swaybar/meson.build')
-rw-r--r--swaybar/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/swaybar/meson.build b/swaybar/meson.build
new file mode 100644
index 00000000..d15e8b5c
--- /dev/null
+++ b/swaybar/meson.build
@@ -0,0 +1,27 @@
1executable(
2 'swaybar',
3 [
4 'bar.c',
5 'config.c',
6 'event_loop.c',
7 'ipc.c',
8 'main.c',
9 'render.c',
10 'status_line.c',
11 ],
12 include_directories: [sway_inc],
13 dependencies: [
14 cairo,
15 client_protos,
16 gdk_pixbuf,
17 jsonc,
18 math,
19 pango,
20 pangocairo,
21 rt,
22 wayland_client,
23 wlroots,
24 ],
25 link_with: [lib_sway_common, lib_sway_client],
26 install: true
27)