aboutsummaryrefslogtreecommitdiffstats
path: root/swaybar/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swaybar/meson.build')
-rw-r--r--swaybar/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/swaybar/meson.build b/swaybar/meson.build
new file mode 100644
index 00000000..fd87e51d
--- /dev/null
+++ b/swaybar/meson.build
@@ -0,0 +1,25 @@
1executable(
2 'swaybar',
3 [
4 'bar.c',
5 'config.c',
6 'event_loop.c',
7 'main.c',
8 'render.c',
9 ],
10 include_directories: [sway_inc],
11 dependencies: [
12 cairo,
13 client_protos,
14 gdk_pixbuf,
15 jsonc,
16 math,
17 pango,
18 pangocairo,
19 rt,
20 wayland_client,
21 wlroots,
22 ],
23 link_with: [lib_sway_common, lib_sway_client],
24 install: true
25)