aboutsummaryrefslogtreecommitdiffstats
path: root/swaybar/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swaybar/meson.build')
-rw-r--r--swaybar/meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/swaybar/meson.build b/swaybar/meson.build
index 312ca97b..b35f8169 100644
--- a/swaybar/meson.build
+++ b/swaybar/meson.build
@@ -1,4 +1,4 @@
1tray_files = get_option('enable-tray') ? [ 1tray_files = have_tray ? [
2 'tray/host.c', 2 'tray/host.c',
3 'tray/icon.c', 3 'tray/icon.c',
4 'tray/item.c', 4 'tray/item.c',
@@ -19,7 +19,7 @@ swaybar_deps = [
19 wayland_cursor, 19 wayland_cursor,
20 wlroots, 20 wlroots,
21] 21]
22if get_option('enable-tray') 22if have_tray
23 if systemd.found() 23 if systemd.found()
24 swaybar_deps += systemd 24 swaybar_deps += systemd
25 elif elogind.found() 25 elif elogind.found()
@@ -42,6 +42,5 @@ executable(
42 include_directories: [sway_inc], 42 include_directories: [sway_inc],
43 dependencies: swaybar_deps, 43 dependencies: swaybar_deps,
44 link_with: [lib_sway_common, lib_sway_client], 44 link_with: [lib_sway_common, lib_sway_client],
45 install_rpath : rpathdir,
46 install: true 45 install: true
47) 46)