summaryrefslogtreecommitdiffstats
path: root/swaybar/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'swaybar/CMakeLists.txt')
-rw-r--r--swaybar/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/swaybar/CMakeLists.txt b/swaybar/CMakeLists.txt
index f59a48fd..373719de 100644
--- a/swaybar/CMakeLists.txt
+++ b/swaybar/CMakeLists.txt
@@ -5,7 +5,13 @@ include_directories(
5 ${PANGO_INCLUDE_DIRS} 5 ${PANGO_INCLUDE_DIRS}
6 ${JSONC_INCLUDE_DIRS} 6 ${JSONC_INCLUDE_DIRS}
7 ${XKBCOMMON_INCLUDE_DIRS} 7 ${XKBCOMMON_INCLUDE_DIRS}
8 ${DBUS_INCLUDE_DIRS}
8) 9)
10if (enable-tray)
11 file(GLOB tray
12 tray/*.c
13 )
14endif()
9 15
10add_executable(swaybar 16add_executable(swaybar
11 main.c 17 main.c
@@ -14,6 +20,8 @@ add_executable(swaybar
14 bar.c 20 bar.c
15 status_line.c 21 status_line.c
16 ipc.c 22 ipc.c
23 event_loop.c
24 ${tray}
17) 25)
18 26
19target_link_libraries(swaybar 27target_link_libraries(swaybar
@@ -24,6 +32,7 @@ target_link_libraries(swaybar
24 ${CAIRO_LIBRARIES} 32 ${CAIRO_LIBRARIES}
25 ${PANGO_LIBRARIES} 33 ${PANGO_LIBRARIES}
26 ${JSONC_LIBRARIES} 34 ${JSONC_LIBRARIES}
35 ${DBUS_LIBRARIES}
27) 36)
28 37
29if (WITH_GDK_PIXBUF) 38if (WITH_GDK_PIXBUF)
@@ -32,6 +41,8 @@ if (WITH_GDK_PIXBUF)
32 ) 41 )
33endif() 42endif()
34 43
44target_link_libraries(swaybar rt)
45
35install( 46install(
36 TARGETS swaybar 47 TARGETS swaybar
37 RUNTIME 48 RUNTIME