aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 6e138101..ced7419c 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -5,9 +5,12 @@ sway_sources = files(
5 'decoration.c', 5 'decoration.c',
6 'ipc-json.c', 6 'ipc-json.c',
7 'ipc-server.c', 7 'ipc-server.c',
8 'lock.c',
8 'main.c', 9 'main.c',
10 'realtime.c',
9 'server.c', 11 'server.c',
10 'swaynag.c', 12 'swaynag.c',
13 'xdg_activation_v1.c',
11 'xdg_decoration.c', 14 'xdg_decoration.c',
12 15
13 'desktop/desktop.c', 16 'desktop/desktop.c',
@@ -64,6 +67,7 @@ sway_sources = files(
64 'commands/force_focus_wrapping.c', 67 'commands/force_focus_wrapping.c',
65 'commands/fullscreen.c', 68 'commands/fullscreen.c',
66 'commands/gaps.c', 69 'commands/gaps.c',
70 'commands/gesture.c',
67 'commands/hide_edge_borders.c', 71 'commands/hide_edge_borders.c',
68 'commands/inhibit_idle.c', 72 'commands/inhibit_idle.c',
69 'commands/kill.c', 73 'commands/kill.c',
@@ -187,6 +191,8 @@ sway_sources = files(
187 'commands/output/max_render_time.c', 191 'commands/output/max_render_time.c',
188 'commands/output/mode.c', 192 'commands/output/mode.c',
189 'commands/output/position.c', 193 'commands/output/position.c',
194 'commands/output/power.c',
195 'commands/output/render_bit_depth.c',
190 'commands/output/scale.c', 196 'commands/output/scale.c',
191 'commands/output/scale_filter.c', 197 'commands/output/scale_filter.c',
192 'commands/output/subpixel.c', 198 'commands/output/subpixel.c',
@@ -204,18 +210,22 @@ sway_sources = files(
204 210
205sway_deps = [ 211sway_deps = [
206 cairo, 212 cairo,
213 drm,
207 jsonc, 214 jsonc,
208 libevdev, 215 libevdev,
209 libinput, 216 libinput,
217 libudev,
210 math, 218 math,
211 pango, 219 pango,
212 pcre, 220 pcre2,
213 glesv2, 221 glesv2,
214 pixman, 222 pixman,
215 server_protos, 223 server_protos,
224 threads,
216 wayland_server, 225 wayland_server,
217 wlroots, 226 wlroots,
218 xkbcommon, 227 xkbcommon,
228 xcb_icccm,
219] 229]
220 230
221if have_xwayland 231if have_xwayland