aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build34
1 files changed, 25 insertions, 9 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 6e138101..d937e425 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -5,24 +5,26 @@ sway_sources = files(
5 'decoration.c', 5 'decoration.c',
6 'ipc-json.c', 6 'ipc-json.c',
7 'ipc-server.c', 7 'ipc-server.c',
8 'lock.c',
8 'main.c', 9 'main.c',
10 'realtime.c',
11 'scene_descriptor.c',
9 'server.c', 12 'server.c',
13 'sway_text_node.c',
10 'swaynag.c', 14 'swaynag.c',
15 'xdg_activation_v1.c',
11 'xdg_decoration.c', 16 'xdg_decoration.c',
12 17
13 'desktop/desktop.c',
14 'desktop/idle_inhibit_v1.c', 18 'desktop/idle_inhibit_v1.c',
15 'desktop/layer_shell.c', 19 'desktop/layer_shell.c',
16 'desktop/output.c', 20 'desktop/output.c',
17 'desktop/render.c',
18 'desktop/surface.c',
19 'desktop/transaction.c', 21 'desktop/transaction.c',
20 'desktop/xdg_shell.c', 22 'desktop/xdg_shell.c',
23 'desktop/launcher.c',
21 24
22 'input/input-manager.c', 25 'input/input-manager.c',
23 'input/cursor.c', 26 'input/cursor.c',
24 'input/keyboard.c', 27 'input/keyboard.c',
25 'input/libinput.c',
26 'input/seat.c', 28 'input/seat.c',
27 'input/seatop_default.c', 29 'input/seatop_default.c',
28 'input/seatop_down.c', 30 'input/seatop_down.c',
@@ -64,6 +66,7 @@ sway_sources = files(
64 'commands/force_focus_wrapping.c', 66 'commands/force_focus_wrapping.c',
65 'commands/fullscreen.c', 67 'commands/fullscreen.c',
66 'commands/gaps.c', 68 'commands/gaps.c',
69 'commands/gesture.c',
67 'commands/hide_edge_borders.c', 70 'commands/hide_edge_borders.c',
68 'commands/inhibit_idle.c', 71 'commands/inhibit_idle.c',
69 'commands/kill.c', 72 'commands/kill.c',
@@ -82,6 +85,7 @@ sway_sources = files(
82 'commands/nop.c', 85 'commands/nop.c',
83 'commands/output.c', 86 'commands/output.c',
84 'commands/popup_during_fullscreen.c', 87 'commands/popup_during_fullscreen.c',
88 'commands/primary_selection.c',
85 'commands/reload.c', 89 'commands/reload.c',
86 'commands/rename.c', 90 'commands/rename.c',
87 'commands/resize.c', 91 'commands/resize.c',
@@ -153,6 +157,7 @@ sway_sources = files(
153 'commands/input/drag.c', 157 'commands/input/drag.c',
154 'commands/input/drag_lock.c', 158 'commands/input/drag_lock.c',
155 'commands/input/dwt.c', 159 'commands/input/dwt.c',
160 'commands/input/dwtp.c',
156 'commands/input/events.c', 161 'commands/input/events.c',
157 'commands/input/left_handed.c', 162 'commands/input/left_handed.c',
158 'commands/input/map_from_region.c', 163 'commands/input/map_from_region.c',
@@ -161,9 +166,11 @@ sway_sources = files(
161 'commands/input/middle_emulation.c', 166 'commands/input/middle_emulation.c',
162 'commands/input/natural_scroll.c', 167 'commands/input/natural_scroll.c',
163 'commands/input/pointer_accel.c', 168 'commands/input/pointer_accel.c',
169 'commands/input/rotation_angle.c',
164 'commands/input/repeat_delay.c', 170 'commands/input/repeat_delay.c',
165 'commands/input/repeat_rate.c', 171 'commands/input/repeat_rate.c',
166 'commands/input/scroll_button.c', 172 'commands/input/scroll_button.c',
173 'commands/input/scroll_button_lock.c',
167 'commands/input/scroll_factor.c', 174 'commands/input/scroll_factor.c',
168 'commands/input/scroll_method.c', 175 'commands/input/scroll_method.c',
169 'commands/input/tap.c', 176 'commands/input/tap.c',
@@ -187,11 +194,14 @@ sway_sources = files(
187 'commands/output/max_render_time.c', 194 'commands/output/max_render_time.c',
188 'commands/output/mode.c', 195 'commands/output/mode.c',
189 'commands/output/position.c', 196 'commands/output/position.c',
197 'commands/output/power.c',
198 'commands/output/render_bit_depth.c',
190 'commands/output/scale.c', 199 'commands/output/scale.c',
191 'commands/output/scale_filter.c', 200 'commands/output/scale_filter.c',
192 'commands/output/subpixel.c', 201 'commands/output/subpixel.c',
193 'commands/output/toggle.c', 202 'commands/output/toggle.c',
194 'commands/output/transform.c', 203 'commands/output/transform.c',
204 'commands/output/unplug.c',
195 205
196 'tree/arrange.c', 206 'tree/arrange.c',
197 'tree/container.c', 207 'tree/container.c',
@@ -204,28 +214,34 @@ sway_sources = files(
204 214
205sway_deps = [ 215sway_deps = [
206 cairo, 216 cairo,
217 drm,
207 jsonc, 218 jsonc,
208 libevdev, 219 libevdev,
209 libinput, 220 libinput,
221 libudev,
210 math, 222 math,
211 pango, 223 pango,
212 pcre, 224 pcre2,
213 glesv2,
214 pixman, 225 pixman,
215 server_protos, 226 threads,
216 wayland_server, 227 wayland_server,
217 wlroots, 228 wlroots,
218 xkbcommon, 229 xkbcommon,
230 xcb,
231 xcb_icccm,
219] 232]
220 233
221if have_xwayland 234if have_xwayland
222 sway_sources += 'desktop/xwayland.c' 235 sway_sources += 'desktop/xwayland.c'
223 sway_deps += xcb 236endif
237
238if wlroots_features['libinput_backend']
239 sway_sources += 'input/libinput.c'
224endif 240endif
225 241
226executable( 242executable(
227 'sway', 243 'sway',
228 sway_sources, 244 sway_sources + wl_protos_src,
229 include_directories: [sway_inc], 245 include_directories: [sway_inc],
230 dependencies: sway_deps, 246 dependencies: sway_deps,
231 link_with: [lib_sway_common], 247 link_with: [lib_sway_common],