aboutsummaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index e16691a8..fee2ddd2 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -2,13 +2,39 @@ sway_sources = files(
2 'main.c', 2 'main.c',
3 'server.c', 3 'server.c',
4 'commands.c', 4 'commands.c',
5 'input/input-manager.c',
6 'input/seat.c',
7 'input/cursor.c',
8 'input/keyboard.c',
5 'commands/exit.c', 9 'commands/exit.c',
6 'commands/exec.c', 10 'commands/exec.c',
7 'commands/exec_always.c', 11 'commands/exec_always.c',
8 'commands/include.c', 12 'commands/include.c',
13 'commands/input.c',
14 'commands/seat.c',
15 'commands/seat/attach.c',
16 'commands/seat/fallback.c',
17 'commands/input/accel_profile.c',
18 'commands/input/click_method.c',
19 'commands/input/drag_lock.c',
20 'commands/input/dwt.c',
21 'commands/input/events.c',
22 'commands/input/left_handed.c',
23 'commands/input/middle_emulation.c',
24 'commands/input/natural_scroll.c',
25 'commands/input/pointer_accel.c',
26 'commands/input/scroll_method.c',
27 'commands/input/tap.c',
28 'commands/input/xkb_layout.c',
29 'commands/input/xkb_model.c',
30 'commands/input/xkb_options.c',
31 'commands/input/xkb_rules.c',
32 'commands/input/xkb_variant.c',
9 'commands/output.c', 33 'commands/output.c',
10 'config.c', 34 'config.c',
11 'config/output.c', 35 'config/output.c',
36 'config/seat.c',
37 'config/input.c',
12 'ipc-json.c', 38 'ipc-json.c',
13 'ipc-server.c', 39 'ipc-server.c',
14 'desktop/output.c', 40 'desktop/output.c',
@@ -28,6 +54,8 @@ sway_deps = [
28 wlroots, 54 wlroots,
29 libcap, 55 libcap,
30 math, 56 math,
57 libinput,
58 xkbcommon,
31] 59]
32 60
33executable( 61executable(