summaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
new file mode 100644
index 00000000..cf2aa913
--- /dev/null
+++ b/sway/meson.build
@@ -0,0 +1,31 @@
1sway_sources = files(
2 'main.c',
3 'server.c',
4 'commands.c',
5 'commands/exit.c',
6 'ipc-json.c',
7 'ipc-server.c',
8 'desktop/output.c',
9 'desktop/xdg_shell_v6.c',
10 'tree/container.c',
11 'tree/layout.c',
12 'tree/workspace.c',
13)
14
15sway_deps = [
16 pixman,
17 wayland_server,
18 jsonc,
19 wlroots,
20 libcap,
21 math,
22]
23
24executable(
25 'sway',
26 sway_sources,
27 include_directories: [sway_inc],
28 dependencies: sway_deps,
29 link_with: [lib_sway_common],
30 install: true
31)