summaryrefslogtreecommitdiffstats
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt27
1 files changed, 0 insertions, 27 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index f9209189..73531a84 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -1,6 +1,5 @@
1include_directories( 1include_directories(
2 ${PROTOCOLS_INCLUDE_DIRS} 2 ${PROTOCOLS_INCLUDE_DIRS}
3 ${WLC_INCLUDE_DIRS}
4 ${WLR_INCLUDE_DIRS} 3 ${WLR_INCLUDE_DIRS}
5 ${PCRE_INCLUDE_DIRS} 4 ${PCRE_INCLUDE_DIRS}
6 ${JSONC_INCLUDE_DIRS} 5 ${JSONC_INCLUDE_DIRS}
@@ -11,37 +10,12 @@ include_directories(
11 ${WAYLAND_INCLUDE_DIR} 10 ${WAYLAND_INCLUDE_DIR}
12) 11)
13 12
14file(GLOB cmds
15 "commands/*.c"
16 "commands/bar/*.c"
17 "commands/input/*.c"
18)
19
20add_executable(sway 13add_executable(sway
21 desktop/output.c 14 desktop/output.c
22 desktop/xdg_shell_v6.c 15 desktop/xdg_shell_v6.c
23 16
24 tree/container.c
25 tree/criteria.c
26 tree/focus.c
27 tree/output.c
28 tree/workspace.c
29 tree/layout.c
30
31 input/input.c
32
33 commands.c
34 ${cmds}
35
36 base64.c 17 base64.c
37 config.c
38 debug_log.c
39 input_state.c
40 ipc-json.c
41 ipc-server.c
42 main.c 18 main.c
43 border.c
44 security.c
45 server.c 19 server.c
46) 20)
47 21
@@ -53,7 +27,6 @@ target_link_libraries(sway
53 sway-common 27 sway-common
54 sway-protocols 28 sway-protocols
55 sway-wayland 29 sway-wayland
56 ${WLC_LIBRARIES}
57 ${WLR_LIBRARIES} 30 ${WLR_LIBRARIES}
58 ${XKBCOMMON_LIBRARIES} 31 ${XKBCOMMON_LIBRARIES}
59 ${PCRE_LIBRARIES} 32 ${PCRE_LIBRARIES}