summaryrefslogtreecommitdiffstats
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index 5b6104f3..51f27a05 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -5,6 +5,8 @@ include_directories(
5 ${JSONC_INCLUDE_DIRS} 5 ${JSONC_INCLUDE_DIRS}
6 ${XKBCOMMON_INCLUDE_DIRS} 6 ${XKBCOMMON_INCLUDE_DIRS}
7 ${LIBINPUT_INCLUDE_DIRS} 7 ${LIBINPUT_INCLUDE_DIRS}
8 ${CAIRO_INCLUDE_DIRS}
9 ${PANGO_INCLUDE_DIRS}
8) 10)
9 11
10add_executable(sway 12add_executable(sway
@@ -24,6 +26,7 @@ add_executable(sway
24 output.c 26 output.c
25 resize.c 27 resize.c
26 workspace.c 28 workspace.c
29 border.c
27) 30)
28 31
29add_definitions( 32add_definitions(
@@ -33,12 +36,15 @@ add_definitions(
33target_link_libraries(sway 36target_link_libraries(sway
34 sway-common 37 sway-common
35 sway-protocols 38 sway-protocols
39 sway-wayland
36 ${WLC_LIBRARIES} 40 ${WLC_LIBRARIES}
37 ${XKBCOMMON_LIBRARIES} 41 ${XKBCOMMON_LIBRARIES}
38 ${PCRE_LIBRARIES} 42 ${PCRE_LIBRARIES}
39 ${JSONC_LIBRARIES} 43 ${JSONC_LIBRARIES}
40 ${WAYLAND_SERVER_LIBRARIES} 44 ${WAYLAND_SERVER_LIBRARIES}
41 ${LIBINPUT_LIBRARIES} 45 ${LIBINPUT_LIBRARIES}
46 ${PANGO_LIBRARIES}
47 ${JSONC_LIBRARIES}
42 m 48 m
43) 49)
44 50