summaryrefslogtreecommitdiffstats
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index 5b6104f3..6c62d676 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -5,6 +5,8 @@ include_directories(
5 ${JSONC_INCLUDE_DIRS} 5 ${JSONC_INCLUDE_DIRS}
6 ${XKBCOMMON_INCLUDE_DIRS} 6 ${XKBCOMMON_INCLUDE_DIRS}
7 ${LIBINPUT_INCLUDE_DIRS} 7 ${LIBINPUT_INCLUDE_DIRS}
8 ${CAIRO_INCLUDE_DIRS}
9 ${PANGO_INCLUDE_DIRS}
8) 10)
9 11
10add_executable(sway 12add_executable(sway
@@ -24,6 +26,7 @@ add_executable(sway
24 output.c 26 output.c
25 resize.c 27 resize.c
26 workspace.c 28 workspace.c
29 render.c
27) 30)
28 31
29add_definitions( 32add_definitions(
@@ -39,6 +42,8 @@ target_link_libraries(sway
39 ${JSONC_LIBRARIES} 42 ${JSONC_LIBRARIES}
40 ${WAYLAND_SERVER_LIBRARIES} 43 ${WAYLAND_SERVER_LIBRARIES}
41 ${LIBINPUT_LIBRARIES} 44 ${LIBINPUT_LIBRARIES}
45 ${PANGO_LIBRARIES}
46 ${JSONC_LIBRARIES}
42 m 47 m
43) 48)
44 49