aboutsummaryrefslogtreecommitdiffstats
path: root/protocols/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/meson.build')
-rw-r--r--protocols/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/protocols/meson.build b/protocols/meson.build
index 124e9777..df24a4e5 100644
--- a/protocols/meson.build
+++ b/protocols/meson.build
@@ -1,9 +1,9 @@
1wl_protocol_dir = wayland_protos.get_pkgconfig_variable('pkgdatadir') 1wl_protocol_dir = wayland_protos.get_variable('pkgdatadir')
2 2
3wayland_scanner_dep = dependency('wayland-scanner', required: false, native: true) 3wayland_scanner_dep = dependency('wayland-scanner', required: false, native: true)
4if wayland_scanner_dep.found() 4if wayland_scanner_dep.found()
5 wayland_scanner = find_program( 5 wayland_scanner = find_program(
6 wayland_scanner_dep.get_pkgconfig_variable('wayland_scanner'), 6 wayland_scanner_dep.get_variable(pkgconfig: 'wayland_scanner'),
7 native: true, 7 native: true,
8 ) 8 )
9else 9else
@@ -15,6 +15,7 @@ protocols = [
15 [wl_protocol_dir, 'unstable/xdg-output/xdg-output-unstable-v1.xml'], 15 [wl_protocol_dir, 'unstable/xdg-output/xdg-output-unstable-v1.xml'],
16 [wl_protocol_dir, 'unstable/pointer-constraints/pointer-constraints-unstable-v1.xml'], 16 [wl_protocol_dir, 'unstable/pointer-constraints/pointer-constraints-unstable-v1.xml'],
17 [wl_protocol_dir, 'unstable/tablet/tablet-unstable-v2.xml'], 17 [wl_protocol_dir, 'unstable/tablet/tablet-unstable-v2.xml'],
18 [wl_protocol_dir, 'unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml'],
18 ['wlr-layer-shell-unstable-v1.xml'], 19 ['wlr-layer-shell-unstable-v1.xml'],
19 ['idle.xml'], 20 ['idle.xml'],
20 ['wlr-input-inhibitor-unstable-v1.xml'], 21 ['wlr-input-inhibitor-unstable-v1.xml'],