summaryrefslogtreecommitdiffstats
path: root/protocols/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/CMakeLists.txt')
-rw-r--r--protocols/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/protocols/CMakeLists.txt b/protocols/CMakeLists.txt
index a9b459ab..8d8e58ad 100644
--- a/protocols/CMakeLists.txt
+++ b/protocols/CMakeLists.txt
@@ -27,6 +27,11 @@ WAYLAND_ADD_PROTOCOL_SERVER(proto-server-gamma-control
27 gamma-control 27 gamma-control
28) 28)
29 29
30WAYLAND_ADD_PROTOCOL_SERVER(proto-server-server-decoration
31 server-decoration.xml
32 server-decoration
33)
34
30add_library(sway-protocols STATIC 35add_library(sway-protocols STATIC
31 ${proto-client-xdg-shell} 36 ${proto-client-xdg-shell}
32 ${proto-client-desktop-shell} 37 ${proto-client-desktop-shell}
@@ -34,6 +39,7 @@ add_library(sway-protocols STATIC
34 ${proto-client-swaylock} 39 ${proto-client-swaylock}
35 ${proto-server-swaylock} 40 ${proto-server-swaylock}
36 ${proto-server-gamma-control} 41 ${proto-server-gamma-control}
42 ${proto-server-server-decoration}
37 ) 43 )
38 44
39set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE) 45set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE)