aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 4 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 766bf012..c50fab17 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,7 @@
1project( 1project(
2 'sway', 2 'sway',
3 'c', 3 'c',
4 version: '1.0',
4 license: 'MIT', 5 license: 'MIT',
5 meson_version: '>=0.48.0', 6 meson_version: '>=0.48.0',
6 default_options: [ 7 default_options: [
@@ -127,17 +128,12 @@ endif
127 128
128add_project_arguments('-DSYSCONFDIR="/@0@"'.format(join_paths(prefix, sysconfdir)), language : 'c') 129add_project_arguments('-DSYSCONFDIR="/@0@"'.format(join_paths(prefix, sysconfdir)), language : 'c')
129 130
130version = get_option('sway-version') 131if git.found()
131if version != ''
132 version = '"@0@"'.format(version)
133else
134 if not git.found()
135 error('git is required to make the version string')
136 endif
137
138 git_commit_hash = run_command([git.path(), 'describe', '--always', '--tags']).stdout().strip() 132 git_commit_hash = run_command([git.path(), 'describe', '--always', '--tags']).stdout().strip()
139 git_branch = run_command([git.path(), 'rev-parse', '--abbrev-ref', 'HEAD']).stdout().strip() 133 git_branch = run_command([git.path(), 'rev-parse', '--abbrev-ref', 'HEAD']).stdout().strip()
140 version = '"@0@ (" __DATE__ ", branch \'@1@\')"'.format(git_commit_hash, git_branch) 134 version = '"@0@ (" __DATE__ ", branch \'@1@\')"'.format(git_commit_hash, git_branch)
135else
136 version = '"@0@"'.format(meson.project_version())
141endif 137endif
142add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c') 138add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
143 139