aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 23 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 1d40581a..2a020323 100644
--- a/meson.build
+++ b/meson.build
@@ -12,6 +12,7 @@ project(
12add_project_arguments('-Wno-unused-parameter', language: 'c') 12add_project_arguments('-Wno-unused-parameter', language: 'c')
13add_project_arguments('-Wno-unused-function', language: 'c') 13add_project_arguments('-Wno-unused-function', language: 'c')
14add_project_arguments('-Wno-unused-result', language: 'c') 14add_project_arguments('-Wno-unused-result', language: 'c')
15add_project_arguments('-DWLR_USE_UNSTABLE', language: 'c')
15 16
16cc = meson.get_compiler('c') 17cc = meson.get_compiler('c')
17 18
@@ -43,11 +44,17 @@ systemd = dependency('libsystemd', required: false)
43elogind = dependency('libelogind', required: false) 44elogind = dependency('libelogind', required: false)
44math = cc.find_library('m') 45math = cc.find_library('m')
45rt = cc.find_library('rt') 46rt = cc.find_library('rt')
46xcb = dependency('xcb')
47git = find_program('git', required: false) 47git = find_program('git', required: false)
48 48
49conf_data = configuration_data() 49conf_data = configuration_data()
50 50
51if get_option('enable-xwayland')
52 conf_data.set('HAVE_XWAYLAND', true)
53 xcb = dependency('xcb')
54else
55 conf_data.set('HAVE_XWAYLAND', false)
56endif
57
51if gdk_pixbuf.found() 58if gdk_pixbuf.found()
52 conf_data.set('HAVE_GDK_PIXBUF', true) 59 conf_data.set('HAVE_GDK_PIXBUF', true)
53endif 60endif
@@ -75,6 +82,8 @@ if scdoc.found()
75 'swaylock/swaylock.1.scd', 82 'swaylock/swaylock.1.scd',
76 'swaymsg/swaymsg.1.scd', 83 'swaymsg/swaymsg.1.scd',
77 'swayidle/swayidle.1.scd', 84 'swayidle/swayidle.1.scd',
85 'swaynag/swaynag.1.scd',
86 'swaynag/swaynag.5.scd',
78 ] 87 ]
79 foreach filename : man_files 88 foreach filename : man_files
80 topic = filename.split('.')[-3].split('/')[-1] 89 topic = filename.split('.')[-3].split('/')[-1]
@@ -123,6 +132,7 @@ subdir('swaybg')
123subdir('swaybar') 132subdir('swaybar')
124subdir('swaylock') 133subdir('swaylock')
125subdir('swayidle') 134subdir('swayidle')
135subdir('swaynag')
126 136
127config = configuration_data() 137config = configuration_data()
128config.set('sysconfdir', join_paths(prefix, sysconfdir)) 138config.set('sysconfdir', join_paths(prefix, sysconfdir))
@@ -176,7 +186,6 @@ endif
176if (get_option('zsh_completions')) 186if (get_option('zsh_completions'))
177 zsh_files = files( 187 zsh_files = files(
178 'completions/zsh/_sway', 188 'completions/zsh/_sway',
179 'completions/zsh/_swaygrab',
180 'completions/zsh/_swaylock', 189 'completions/zsh/_swaylock',
181 'completions/zsh/_swaymsg', 190 'completions/zsh/_swaymsg',
182 ) 191 )
@@ -184,3 +193,15 @@ if (get_option('zsh_completions'))
184 193
185 install_data(zsh_files, install_dir: zsh_install_dir) 194 install_data(zsh_files, install_dir: zsh_install_dir)
186endif 195endif
196
197if (get_option('bash_completions'))
198 bash_files = files(
199 'completions/bash/sway',
200 'completions/bash/swayidle',
201 'completions/bash/swaylock',
202 'completions/bash/swaymsg',
203 )
204 bash_install_dir = datadir + '/bash-completion/completions'
205
206 install_data(bash_files, install_dir: bash_install_dir)
207endif