aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 16 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 76eaff20..1e7ce281 100644
--- a/meson.build
+++ b/meson.build
@@ -42,7 +42,6 @@ pango = dependency('pango')
42pangocairo = dependency('pangocairo') 42pangocairo = dependency('pangocairo')
43gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: false) 43gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: false)
44pixman = dependency('pixman-1') 44pixman = dependency('pixman-1')
45libcap = dependency('libcap', required: false)
46libinput = dependency('libinput', version: '>=1.6.0') 45libinput = dependency('libinput', version: '>=1.6.0')
47libpam = cc.find_library('pam', required: false) 46libpam = cc.find_library('pam', required: false)
48systemd = dependency('libsystemd', required: false) 47systemd = dependency('libsystemd', required: false)
@@ -74,6 +73,11 @@ if elogind.found()
74 swayidle_deps += elogind 73 swayidle_deps += elogind
75endif 74endif
76 75
76if not systemd.found() and not elogind.found()
77 warning('The sway binary must be setuid when compiled without (e)logind')
78 warning('You must do this manually post-install: chmod a+s /path/to/sway')
79endif
80
77scdoc = find_program('scdoc', required: false) 81scdoc = find_program('scdoc', required: false)
78 82
79if scdoc.found() 83if scdoc.found()
@@ -124,7 +128,16 @@ else
124endif 128endif
125add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c') 129add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
126 130
127add_project_arguments('-D_LD_LIBRARY_PATH="@0@"'.format(get_option('ld-library-path')), language: 'c') 131if get_option('use_rpath')
132 if get_option('custom_rpath') == ''
133 # default to platform specific libdir, one level up from the binary
134 rpathdir = join_paths('$ORIGIN', '..', '$LIB')
135 else
136 rpathdir = get_option('custom_rpath')
137 endif
138else
139 rpathdir = ''
140endif
128 141
129sway_inc = include_directories('include') 142sway_inc = include_directories('include')
130 143
@@ -139,10 +152,7 @@ subdir('swaybg')
139subdir('swaybar') 152subdir('swaybar')
140subdir('swayidle') 153subdir('swayidle')
141subdir('swaynag') 154subdir('swaynag')
142 155subdir('swaylock')
143if libpam.found()
144 subdir('swaylock')
145endif
146 156
147config = configuration_data() 157config = configuration_data()
148config.set('sysconfdir', join_paths(prefix, sysconfdir)) 158config.set('sysconfdir', join_paths(prefix, sysconfdir))