aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 4 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index bd20ca99..57dbea02 100644
--- a/meson.build
+++ b/meson.build
@@ -19,13 +19,12 @@ is_freebsd = host_machine.system().startswith('freebsd')
19datadir = get_option('datadir') 19datadir = get_option('datadir')
20sysconfdir = get_option('sysconfdir') 20sysconfdir = get_option('sysconfdir')
21prefix = get_option('prefix') 21prefix = get_option('prefix')
22libexecdir = get_option('libexecdir') 22instlibdir = get_option('instlibdir')
23 23
24if libexecdir == '' 24if instlibdir == ''
25 libexecdir = 'lib' 25 instlibdir = join_paths(prefix, 'lib/sway')
26endif 26endif
27sway_libexecdir = join_paths(prefix, libexecdir, 'sway') 27add_project_arguments('-DINSTLIBDIR="/@0@"'.format(instlibdir), language : 'c')
28add_project_arguments('-DSWAY_LIBEXECDIR="/@0@"'.format(sway_libexecdir), language : 'c')
29 28
30 29
31jsonc = dependency('json-c', version: '>=0.13') 30jsonc = dependency('json-c', version: '>=0.13')