aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index d2c8d3ad..b0aa3200 100644
--- a/meson.build
+++ b/meson.build
@@ -76,8 +76,6 @@ endif
76 76
77wlroots_features = { 77wlroots_features = {
78 'xwayland': false, 78 'xwayland': false,
79 'systemd': false,
80 'elogind': false,
81 'libseat': false, 79 'libseat': false,
82} 80}
83foreach name, _ : wlroots_features 81foreach name, _ : wlroots_features
@@ -318,7 +316,7 @@ summary({
318 'man-pages': scdoc.found(), 316 'man-pages': scdoc.found(),
319}, bool_yn: true) 317}, bool_yn: true)
320 318
321if not wlroots_features['systemd'] and not wlroots_features['elogind'] and not wlroots_features['libseat'] 319if not wlroots_features['libseat']
322 warning('The sway binary must be setuid when compiled without (e)logind or libseat') 320 warning('The sway binary must be setuid when compiled without (e)logind or libseat')
323 warning('You must do this manually post-install: chmod a+s /path/to/sway') 321 warning('You must do this manually post-install: chmod a+s /path/to/sway')
324endif 322endif